Ford Powerstroke Diesel Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 99E F-250 SD with a 7.3 225,000 miles that I am working on. I took over this project after the last owner let it sit for over 4 months. When I started working on it he had put the wrong pedestal, up pipes on it and then just let it sit. Sense I purchased it I have installed the correct up-pipes, new 99E pedestal and put everything back together. I started it after priming the fuel system and it's now running very rough, surging and sounds like the worst case of rod knock ever. Sense the first start I have replaced the ICP, IPR, CPS, fuel filter and cleaned the screens in the tank. I also checked the valve cover plugs, made sure injectors were firing with the buzz test and visually with oil pouring out and still can not get this thing running correctly. Being new to the diesel world and checking everything I found thru forums and videos can someone point me in the right direction as what to do next or what else I can check?
 

·
Premium Member
Joined
·
11,487 Posts
What was the original owner trying to fix or mod before letting it sit for 4 months? It would help a ton knowing more of the trucks backstory etc. 4 months is nothing for letting a truck sit. Ya maybe some crud in the fuel system and flat spots on tires but nothing mechanically should go wrong at all. We oversaw many of our troops vehicles when they sat for 8+ months for deployments etc. Battery tender on jack stands or driven weekly etc.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top