Ford Powerstroke Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i have a 1999 ford f-350 4x4 diesel 7.3 ,the entire driverside bank of injectors is not firing.the truck has a check engine light but my computer will not conect through any function.the truck runs verry rough and has absolutley no power.i pulled the wiring harnes off that bank and no change what so ever if i disconect the otherr side the truck will shut off.i removed the driverside valve cover to see if the conection with the internal wiring harnes was good the conection is tight and clean .if i give the truck fuel it will slowley raise the rpm gaudge and seems to run smoother but as soon as you let off it goes strait back to running rough and powerless.sometimes i notice white smoke when starting and it always starts hard.ive replaced the gasket/harness in the driverside valve cover also.i was thinking it had something to do with the wiring harnes leading to the injectors or the computer that controls it all,but then again if the computer was bad could it only cause one bank to go bad?some people have told me i may have a bad injector but removing the wiring hsarnes to the entire bank doesnt change anything which shows it is not running off any of them , anyone have any ideas on what might be wrong ,please help
 

·
Registered
Joined
·
57 Posts
Find another idm and swap it out, a bad idm will do the same thing
 

·
Registered
Joined
·
57 Posts
Idm ( injector driver module) located in the drivers fender well.
 
1 - 3 of 3 Posts
Top