Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
I have a 99 f250 7.3 manual w/ php 6 pos chip. Couple weeks ago when pull ing out of driveway I lost pedal and it wouldnt rev up. Turned key off and it worked fine again. Last night while getting on highway witht the hammer down it lost all power. I could hardly keep truck going 45 and couldnt get off highway due to construction. I pulled off soon as I could and inspected under hood, no oil or fuel leaks. I limped it to my parents house. I would slightly flash CEL at times but never came all the way on, it had a hard time starting out in first gear at stop lights and would clunk out. It spun and spun and spun and would start again (but I never had key clicked all the way off). I made it to the drive way, shut it off and went in house to get flash light. I came back out started it and it ran fine. Today driving home, same thing getting on onramp (80hp dailydriver tune) with my foot in the pedal lost power, pulled over shut it off to remove key position. It reset and ran fine. I cant recall what tune I was in for the other times it failed but Ive tryed to dupilcate it without success in stock position and in other tunes. Oil has 500 miles on it, newer fuel filter. CPS is about a year old and it s a Ford one, grey if I recall. Im thinking its something electrical due to it resets with key off. Idk if its chip, CPS or bad TPS, truck just turned 300k and I dont know if its ever been replaced. I need to fix this cause its going to happen someplace bad agin like lastnight. Any thoughts?
 

·
Registered
Joined
·
170 Posts
I have the same issues I have been trying to track down for a while.

when I am going down the road it Will shut off and I Will have to turn the key off and restart/crank the truck while going down the road.
 
1 - 2 of 2 Posts
Top