Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey I’m looking to see if anyone knows everything that is linked to fuse #30 under dashboard, yesterday I was doing something to my truck and I had it running and I pulled fuse 30 on accident and it killed the truck after putting the fuse back the truck won’t start and once the key goes on the batteries drain down to 8v immediately,the batteries have been fully charged and the issue is still present,I swapped the idm and pcm with no Change
 

·
Premium Member
Joined
·
8,476 Posts
The reason it won't start IS that 8v though (probably drops that low because of the Glow Plug activation and drops even farther once the starter motor is engaged).

The PCM needs to detect a higher voltage before it will trigger the IDM to fire the injectors (in a '99.5 not below 10v). You Must be able to maintain a higher voltage with Both the GPs and Starter running or it will Never start. Charge the batteries up fully, if they can't handle the load without maintaining enough voltage you need to find out why (either bad batteries or a bad connection). To properly test the batteries have them Load Tested, at a High rate (250-300A, not one of those dinky 100A testers the Parts Stores use on sm gas engines, we need a high load for our high capacity batteries for it to be a valid test)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Gotcha, I just wasn’t sure if I fried or shorted any electrical components when I accidentally pulled the #30 fuse while it was running,I had the batteries charging for a couple hours and cranked it and it did start but ran rough so I shut it down after a few seconds and then they went back to draining quicker then normal with key on after that, I now took them
Both off the truck to be fully charged then I’ll try a load test on both and go from there,I’m hoping the batteries are the problem lol
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I charged the batteries overnight and changed back to my stock IDM and the truck starts and idles perfect,I’m guessing like you mentioned batteries were just drained
 
1 - 5 of 5 Posts
Top