Ford Powerstroke Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
need help I'm ready to pull my hair out. started the truck up one day was letting it idle and just like that the truck shut off. will not start. there was a ground wire on the left side kick panel that was not grounded at the time but now it and still no start. I have tach movement, wait to start light comes on, hpop is full, fuel bowl fills and all fuse are good. I cant connect to obd port because it says can not connect to ecm. NEED HELP!
 

·
Registered
Joined
·
1,637 Posts
pull each valve cover...I bet you have a faulty UVCH. Look for burnt wiring on the harness on both heads, also while you have the valve covers off confirm oil is coming from all 8 injectors while cranking indicating they are firing.
 

·
Registered
Joined
·
2,874 Posts
Is the CEL illuminated? What are you trying to use to connect to the PCM? Most generic scan tools cannot connect to these trucks. Cheers!
 

·
Registered
Joined
·
3,835 Posts
Any smoke while cranking? If not then a buzz test is in order and HPOP and fuel pressure needs to be checked while cranking.
 

·
Registered
Joined
·
3,835 Posts
A bluetooth adapter and an android device with Car Gauge Pro app will do everything you need.

No smoke means injectors aren't firing. Either no fuel pressure, no HPOP pressure and/or no signal to fire.

At this point you can point to IDM or possibly PCM if a good device won't connect.

If you can locate a spare IDM and do a quick swap you can rule that out.

A PCM swap will need to be one similar to yours.
 

·
Registered
Joined
·
1,637 Posts
pull each valve cover...I bet you have a faulty UVCH. Look for burnt wiring on the harness on both heads, also while you have the valve covers off confirm oil is coming from all 8 injectors while cranking indicating they are firing.
pull each valve cover...I bet you have a faulty UVCH. Look for burnt wiring on the harness on both heads, also while you have the valve covers off confirm oil is coming from all 8 injectors while cranking indicating they are firing.
 

·
Registered
Joined
·
288 Posts
You can also try unplugging the icp on the driver side head, it goes to a default pressure, and will typically start if it's not reading properly, if it still doesnt start pull the icp and put a rag over the hole and crank it a little it should shoot out oil, if not then you have a bad hpop or the ipr is stuck open and not building pressure.
 
1 - 11 of 11 Posts
Top