Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Well it all started with the glowplugs. I heard these horror story's of these things lodging them selves in your engine, so i decided to change them out. It was all smooth i went to the passenger side first and they came out fine. Went to the driver's side and all came out except the one closest to the grill the parts that came out were the outer casing and the top tip of it that the wire plugs on to, the main part of the glow plug (the middle of it that gets hot) was just sticking out of the hole so tried puttin some elbow grease into it and i couldnt get it out. So i put the glowplug back together and the truck ran just as good as it did if not better so i called a few ppl and my aunt hooked me up with a mechanic at her work that said he could get it out. They tried everything but drilling it out and taking the head off so pretty much they did what i did and yanked on it a lot they said they put a chain on it or something, i'm not sure long story short the guy didnt get paid. The problem is it runs like **** now they said the put the glow plug back together like i had it and everything. But it runs terrible it has no power, shakes, has a rough idle and sounds bad to and through out the RPM's it doesnt level out either there is no smoke or anything, i talked to the mechanic again and he said he may have shaved a good enough amount of metal off the glowplug to wear it may not have a good seal on it and it could be leaking compression and thats why its shaking so bad and running terrible so i was gonna take it to a real diesel mechanic which is gonna cost me a nice amount of cheese to get it worked on but i just wanted to write in and make sure that its the compression or could it possibly be something else that i could have checked, i know the glow plug has to come out and they could be all it is but i want to be prepared for the worse, there are no engin codes been thrown on the dash. Its bad enough were its hard to sleep at night :hehe: but yeah any information would greatly be apprecited, than you.
 

·
Registered
Joined
·
61 Posts
try checking the wire harness to see if its loose. sounds like signs of a failing wire harness. either change the harness or get the wedge to make it fit tighter. you could eve use small zip ties to secure the harness together. hope this helps.
 
1 - 2 of 2 Posts
Top