Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
So i swamped my truck in 5ft of water and took me a year and many thousands later to sort out everything and get it running again however it wont run for more than a few minutes then dies even with the throttle.It doesnt even sputter,it just stops,replaced cam sensor,fuel pump,straight piped from turbo back,ipr orings,idm,pcm,gpr,glow plugs,both vc harnesses,relays all good and fuses,fuel bowl heater disconnected for years and have all fuel pressures and isnt throwing any codes.Injectors are all good as well as hpop and lpop.redid and rechecked ipr wiring as it was worn and coolant sensor wire has not chaffed against pulley.Im really stumped guys,ive even unplugged and replugged all my sensors and it doesnt change a thing.Any thing ive missed anyone can think of?This is beyond frustrating.
 

·
BANNED by Kris
Joined
·
6,317 Posts
Pull the cover off the IDM and have a gander.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
its a new idm,now truck starts then dies instantly and sometimes wont even start at all!im still getting rpm while cranking so my new cps didnt crap out either.
 

·
BANNED by Kris
Joined
·
6,317 Posts
There are three F250's in '94 and all with a 7.3L diesel engine. Do you have a early '94, early '94 turbo, or late '94?
 

·
Registered
Joined
·
37 Posts
Discussion Starter #5
like i said its a dit,first gen powerstroker,i still consider myself an amatuer stroker but this is something even the pros are scratching their heads at.It should be running but its not, only thing that makes sense is that maybe,and a big maybe is it might be taking awhile to purge the air out of the system but i dont think so,i had it running for half hour b4 it quit and now it fires for a second then dies no sputter,then she cranks with no start,leave it and she start and dies instantly again and wont start again.this is driving me nuts.
 

·
BANNED by Kris
Joined
·
6,317 Posts
Sorry You did say dit in the title. Do you have a Digital Volt Meter? On the IDM connector in position 14 there is a Dark Green wire with a light green stripe. Back probe the wire at the IDM connector and see if Pos voltage is present every time you go to fire the truck. After the truck starts it should continue to have a 12v positive voltage until you manually rotate the key back to off. Is this true in your situation?

-If it doesn't come on then there might be a short in the PCM relay is overheating or wiring that controls it that when hot cuts out.

-If it does come on and then goes off after running for a few minutes then there is a short in the IDM relay or it's wiring doing the same thing as the possible PCM relay.

-If it stays on the whole time then check the Black wire / White stripe on pin position 26 of the IDM. This is the hard negative for the IDM. If it is cutting out then you will need to trace it to the body and make a new ground.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #7
killed my batteries,ill try again tmrw,ill swap some relays and test those wires.any other thoughts would be great.this is killin me.a full year and thousands in parts and its still not going right,at least it starts now....well sort of.lol
 

·
Registered
Joined
·
37 Posts
Discussion Starter #8
I really was hoping you were right but no luck.I replaced my ipr rings but im leaning towards the en tire unit being pooched.so i will keep u posted.big fuel,ive read some of your other posts and sounds like you have your head wrapped around these strokers pretty good,any other input you may have would be appreciated.Im beyond newbies trying their two cents.so far your the only one thats provided me with input i didnt think to check so thanks again,one more thing it wasnt.lol
 

·
Registered
Joined
·
37 Posts
Discussion Starter #9
ITS FIXED!!!!!

I finally fixed it!pulled apart my IPR after i put in rings an installed it already,i just couldnt shake off that it was the ipr so i pulled it out again and this time i pulled the needle out of it and cleaned everything out,got a tiny little piece of red crap(rust),put er back together and bam,she fired,idled,ran like a raped ape and idle again with NO shutdowns!!!!Thank you all for all your help!:thumb:p.S. id like to throw a big TY to big fuel as he gave me enough other ideas that i knew it HAD to be my ipr,so a special thanks to you big fuel.
 

·
BANNED by Kris
Joined
·
6,317 Posts
Great to hear that you are back on the road.

Thank you and Happy Tugging!
 
1 - 10 of 10 Posts
Top