Ford Powerstroke Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey psd master's i'm having trouble with my 94. I had the mechanical fuel pump in the valley replaced and the truck died 2 or 3 miles after leaving the shop. I left it in gear to keep the motor spinning as it was coasting to a stop hoping it would roll start back up but it didnt until i got down to second gear and cycled the key once. Pretty thankful that it fired. Another mile down the road it did it again so i just kept cycling the key every time it quit on me never having to come to a full stop. 30 miles later and 30 or 40 repeats of this and the 94 got me home! After cycling the key it would roll start exactly 3 seconds later and keep driving but not over 40 and not in 5th gear. The next morning a no start condition. I have been helped out alot in the past by just reading your guy's post's this is my first thank you for reading.
 

·
Premium Member
Joined
·
23,190 Posts
Do you have a idi or psd?
If the psd have you swapped the CPs lately? Is it throwing any codes, does it did if left to idle long, or only when in motion?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
This problem is with my psd never changed the cps but after reading a few threads i feel the idm/ipr may be to blame 90,000 miles on this one.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Only did it in motion, never let it idle more than a few minutes. Havent checked for codes but there isn't any lights showing up on the dash.
 
1 - 4 of 4 Posts
Top