Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
My 01 X is not wanting to start periodically .mine spins over until battery dies after trying to start it 3 to 4 times spinning it over for 60 seconds each. glowed it 3-4 times before spinning it. glow plugs has a module not relay and does not have a code. battery doesnt completely die but gets weak and i jump it off with my 4.0l ranger. then when jumped off it fires right up usually on the first try. if it sets for 18-24 hrs back to the same thing. it will start any time after jumping, even if you cut it right back off with jumper cables disconnected. any suggestions? i have an otc genysis scan tool but do not know what to look for. this is my 1st diesel engine vehicle. local ford dealer suggested injector driver module because it had code p1670 (ef signal not detected) once but has not come back on in 3 weeks since i cleared it. the code came on when the battery died while trying to start it. fired up as soon as i jumped it.
 

·
Premium Member
Joined
·
5,133 Posts
Make sure your batts are good. Sometimes, the batteries will sound like they are strong enough, when they really arent. Almost seems that way when you hook the jumper cables to it and it starts right up. Also, since you have a scan tool, monitor your ICP (Injection Control Pressure) while cranking. Your engine will not start if it doesnt build 500 psi. Once you eliminate those 2 possibilities, we can go from there.
 

·
Registered
Joined
·
333 Posts
my 02 ex did the same thing to my wife ended up being the chip in her key was bad ?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
going to test batteries today with my ed-18. i have 2 new insterstate mtp-65batteries if they are bad. i will also check the pressure later today also.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
1 batterry good 1 bad replacing both. icp would not give pressure until after i jumped it off kept killing the power to the scan tool while trying to crank before jumping it off. i still keep getting soft code p1670 ef signal not detected.
 
1 - 5 of 5 Posts
Top