Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter #1
Well it seems I'm having some issues with my new PSD (1996 F250). It takes a few cycles of the glowplugs to fire up in the mornings, even when its 40 degrees out. It blue smokes and when I pull away it normally smokes a nice cloud like i'm fogging for mosquitos. The rest of the day it cold starts fine.

I noticed when i'm taking off (2nd gear), It looses power and I guess bogs around 2,000 rpms. It takes a second to get over that and then it goes on as normal. Sometimes at that Bog rpm range I get alot of blue smoke just like before. Also if I free rev it smokes in that range.

I'm not sure if this has anything to do with it but the truck is from California, and its now in Northern IL. Emissions? Different Diesel Fuel? I'm currently running some Diesel Treatment through it to see if anything changes. It only has like 85,000 on a brand new Ford crate motor done by ford, and 180,000 on the truck. There are no leaks, and I drove it home 2100 with no problems and didn't burn a drop of oil. Any ideas?

I don't want to further damage anything being I just spent alot of cash on the truck!!!
 

·
Registered
Joined
·
7,223 Posts
First issue sounds like a few bad glow plugs or maybe a bad GPR. The 2000rpm bog/smoke...I would say air/fuel? I'm sure someone else will have dealt with that before.

Just my opinion but I wouldn't be starting in second all the time...unless you like changing clutches lol.
 

·
Registered
Joined
·
168 Posts
Discussion Starter #3
I was told it has new glowplugs, but theres a difference between Autolite Glowplugs and the OEM Plugs. I'm going to test the relay and the plugs this weekend.

I'm more worried about the loss of power in second gear.
 

·
Registered
Joined
·
7,223 Posts
It only does it in second gear?? Standard trans?
 

·
Registered
Joined
·
168 Posts
Discussion Starter #5
Yes 5spd and only in second gear. I'm kinda stumped.

I just don't know if bringing it home from a different climiate with different emissions had anything to do with it...
 

·
Registered
Joined
·
7,223 Posts
If it's a five speed and it only does it in second gear at 2000 rpm then I have absofrickinlutely no idea what the problem may be. To be honest that really doesn't make any sense. Sorry dude :dunno:

Are you sure you aren't imagining it? :hehe:
 

·
Registered
Joined
·
168 Posts
Discussion Starter #7
I wish I was. But I pulled away from a stop light and fogged a whole intersection. It doesn't do it everything time, so it is very weird. I just happened to notice it when looking back. When I got home I gave it a few revs in the driveway and was getting some pretty good smoke. I'm stumped.....
 
1 - 7 of 7 Posts
Top