Ford Powerstroke Diesel Forum banner

1 - 8 of 8 Posts

·
KVFD
Joined
·
4,061 Posts
Discussion Starter · #1 ·
Ok so my battery light came on last week. I am working nights and dont get time to go to town. So i ran it until it had no more battery:doh: I figured a alternator. So the other day i picked up a alternator and put it on and i jump started the truck. Set it on high idle and it never charged batteries. so i charged batteries up to 13.5 volts and then started it and did the odometer trick to monitor the voltage. within a half hour it droped to 11.5 volts and the light came back on. Any ideas:dunno: A buddy thinks maybe a bad glow plug drawing alot of juice idk??? where do i start
 

·
Premium Member
Joined
·
18,040 Posts
Sounds like a short somewhere. Man, that would be hard to trace down......I would start by checking the GP relay.....See if its sending voltage to the GP's all the time.....
 

·
KVFD
Joined
·
4,061 Posts
Discussion Starter · #3 ·
Dude it all started last week and it just started there is no smoking or anything
 

·
International Threat
Joined
·
13,087 Posts
This is where I would start...

Take a test light and test all of your under hood/under dash fuses and see if there is one still on when the key is out of the ignition.

Clean the battery cables ends and battery posts as good as possible.

Here is the GPR, just unhook the power wire going to it.
http://www.powerstroke.org/forum/7-3-repair-help/45887-glow-plug-aih-relay-locations.html

It will help to do this after the truck has been running and is up a few degree's. Dunno how the weather is out there.

That should get you started...
 
1 - 8 of 8 Posts
Top