Ford Powerstroke Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 2001 7.3 and up until a couple of weeks agao truck would pull just fine. Now when I hook to our 20' gooseneck with the asphlt paver on it roughly 15,000 pounds the truck will barely puul out of its place. once i finally get going my tranny temp goes sky high everything else is fine. Just rebuilt the turbo, all intercooler boots are ok, replace accumalator body in trans and im going to replace the icp sensor and harness on monday because mine is caked with oil. Ive read on other post maybe bad torque converter or cracked flywheel but im clueless and i really need this truck. Any help will be much appreciated!!!!!!!!!!!!
 

·
Registered
Joined
·
11,152 Posts
Did it happen after you did the turbo?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
The squealing quit before rebuild and could tell something was funny, and tranny temp was getting hotter than normal.
 

·
Registered
Joined
·
1,888 Posts
With a cracked flywheel, you'd hear it at idle. Sounds like marbles in a can. The noise goes away with a slight hit of the pedal.

I think your on to something though, with the TQ. Could be, its not locking.
 

·
Registered
Joined
·
11,152 Posts
TC not locking will cause a high temp while running. You'll notice the TC unlocked versus locked.
TC doesn't lock when taking off though.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
I was thinking maybe the TQ was slipping
More that it was supposed to. I'm not sure. My edge CS has the monitor and it shows when TQ is locked up or not and seems normal but it could just be saying it is but that is in 3rd and 4th gear. But now power at all when pulling a trailer wether in take off or running 50.
 

·
Registered
Joined
·
11,152 Posts
What are your boost numbers?
 

·
Registered
Joined
·
1,888 Posts
think, you need to get the truck "read". Yoiu/know anybody with a reader, to read these trucks. I'm a rookie at this point, but i think you'll want to know the ICP and duty cycles, C.C.T. test, maybe throw in a buzz test while your at it.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Ok, a little late on the update, took it to local diesel shop and he ran all the test the he could on it, injectors, turbo, wastegate, everything fine except my ebp sensor and tube was clogged up so bad the was no cleaning just replacing. replaced tube and sensor and truck still does the same thing, doesnt throw any code at all, im helpless at theis point:dunno::confused:
 

·
Registered
Joined
·
1,888 Posts
if a bad flywheel, you'd hearthat at idle...marbles in a can sound. After re-reading your post, sounds like a TQ issue.
 

·
Registered
Joined
·
465 Posts
Whats your fuel pressure while towing?

Fuel pressure is not monitored by the ECU.
 
1 - 13 of 13 Posts
Top