Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
08 6.4 powerstroke
Egr delete
Dpf delete
Elc coolant after restore/restore + flush
New thermostats
New degas bottle
Pluged oem oil cooler with BPD half kit installed for oil cooling


I have intermediate puking and idle heat loss. Drove it a few day ago it puked. Drove around with cap off got lots of air out squeezing upper radiator hose. Dove same route that it puked a couple times and cant get it to puke again. When i park I noticed the coolant has rose about 2”. After cooling for 10 min with engine off the level was almost at the top. I did this twice same thing happed each day. After the first time it never went back down even overnight so i let it idle and got is to go down squeezing upper radiator hose but not all the way it only went to right above DO NOT (possible because it was at 185 be the time i put the cap back on after removing air). After taking the same drive with a few hills abut 30 min. I park it and after 10 min its up to the top while cooling, when i open the cap there was not much pressure and the level went down a little.
Were is the air coming from while it is cooling down?
 

Attachments

·
Registered
Joined
·
1,242 Posts
I would start by draining the whole system and doing a vacuum refill. Then fill the coolant so it is close to the the bottom minimum fill mark on the tank. It is general consensus that the max fill mark is over full on 6.4’s which leads to loss of coolant and over-rising coolant level.
 

·
Registered
Joined
·
496 Posts
So Derrik41, did you figure out what was causing this? I'm having a similar issue although not as bad as yours.
 

·
Registered
Joined
·
1,681 Posts
I thought you said your 6.4 hasn't given you any problems aside from body mounts?

 

·
Registered
Joined
·
496 Posts
Mines not puking or running hot (even when towing my 20K lb trailer) so no, its not a problem, I even stated "although not as bad as yours." in the post . It's something I'm keeping an eye on to see what develops from it.
I did replace the rad with a mishimoto one a few years ago because I broke my stock rad being stupid with bad body mounts. I was hoping there is a known way/ method to get this last bit of air out of the cooling system (as yes I vacuum filled mine when I replaced the rad). But just looking at the system, the upper rad hose is higher than the fill line on the degas bottle (and yes I have the updated degas bottle).

So I stand by my statement that it hasn't given me any trouble other than body mounts. I have done a few modifications and a lot of maintenance, but its never failed to get from from point A to point B when I've asked it to.
.
.
.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
The problem i think is from 2 things. The cap wasn't sealing and reliving pressure fast once i turn the engine off causing the fluid to rise. I also think my head bolts are stretched allowing extra air in the system and pressurizing it under high boost. Im going to attempt to replace the head bolts with arp studs without removing the heads hoping the gasket are still good and and see if the torque of the studs stops the pressureized air from getting in.
 
1 - 6 of 6 Posts
Top