Ford Powerstroke Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
So my mechanic that works on my 05 6.0 is having trouble figuring out what is wrong with it... the truck will fire on the third or fourth time of cranking when cold around (20-30 degrees) and wont run right until its warm then runs perfectly fine could anybody help me out with what causes this and what i need to do to fix it.
Thanks...
 

·
Registered
Joined
·
6,023 Posts
First off welcome to the site!
Do you happen to have any type of a monitor on your truck? (Edge,scanguage,livewire...etc.?)
 

·
Registered
Joined
·
2,897 Posts
First thing I would do is 8 new glowplugs and a relay... especially if youve tried ether starting it
 

·
Registered
Joined
·
460 Posts
Check FICM voltage. Search that and you will see what it is supposed to be at when cranking
 

·
Registered
Joined
·
6,023 Posts
You gotta get a monitor. Right now your truck cannot communicate with you.
 

·
Registered
Joined
·
6,023 Posts
that's for tunes. You gotta get a monitor. basically a small computer that plugs into your obdII port under your steering wheel and displays your settings on your truck and can also read trouble codes.
 

·
Registered
Joined
·
6,023 Posts
Ive got the Edge cts. its about $400 which seems spendy. But it can save you a lot more money. Mine has paid for itself multifolds...

You can also check out livewire. I have not tried this but from what I understand it uses your phone as a display screen.

ScanguageII. Saw it today in the campinworld flyer for $160. A lot of guys have these as well.
Banks has a set up as well.
 

·
Registered
Joined
·
2,897 Posts

·
Registered
Joined
·
2,897 Posts
1 - 16 of 16 Posts
Top