Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I'm currently working on a 03 f250 with the 6.0 that has nothing but problems.

Heres the history on this truck as far as i know.

Last October the HPOP was replaced.
Last Month the number 2 injector was replaced. the mechanic that replaced it somehow screwed the injector up and he had to remove and install another one. But he managed to screw it up again. The third time a different mechanic replaced it correctly.

Now the truck will only crank. the ecu was throwing a code for a crank position sensor. So we replaced that with a new one from Ford. Then it threw a code for a icp sensor. So we replaced that with a new one from Ford also. Before that i had the scanner hooked up and watched the realtime data and the icp voltage was at 0.15 and wasnt showing icp pressure. Once we replaced it Icp press was 1622 - 1633 while cranking but icp voltage was 0.0. We've checked all the wiring, fuses, everything for any leaks but cannot find any. I have even pulled the valve covers to check for leaks while cranking. None.

My boss told me that the HPOP is going to bneed to be replaced again but to search for any other possibilities first. So is there any other options?
Also are there any online diagrams/instructions for HPOP removal and installation?
 

·
Registered
Joined
·
119 Posts
Ok look for several things first make sure you have base engine oil pressure. If so then you need to check for leaks in the hp oil system could be a branch tube or som,ething of that nature. If you find nothing then I would say replace the pump. If its under 12000 miles since that last replacement you can use SPW (service part warranty) to replace it.

Im just guessing you work for a dealership. If not then replace the pump anyways it will just cost them.


How did they screw up an injector on a 6.0L? Ive done it on 7.3 before by putting the bolts in the wrong spot. and the snap........well we all kn,ow how things happen on these trucks.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
If you find nothing then I would say replace the pump. If its under 12000 miles since that last replacement you can use SPW (service part warranty) to replace it.
the truck has 140+ miles so theres no warranty left.



Another question is how can i remove the hpop without removing the cab?
 

·
Registered
Joined
·
119 Posts
12k miles since the last pump install. There is a 12k 12 mo warranty on all parts.

Just pull the turbo off and take the ipr and icp out. Then remove the hpop cover....youll need either my little special bent wrench or som,e patience to get the 3 bolts from, under the egr cooler and they will stay with the pump plate so dont even try to get them out. Loosen your y pipe tubes at the manifold and remove the egr cooler exhaust clamp. then pop the plate off and remove the bolts and the pump. it takes about 4.5 hrs with cleaning the surface to remove and install. If its your first just dont get frustrated with it and take your time. Any questions just ask me or any other techs on here.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
well it took me about 6.5 hours to get the hpop out, which that was a pain in the rear. the customer came and picked it up and got a remanufactered one. so ill be busy tomorrow.
 

·
Registered
Joined
·
119 Posts
It gets easier with time.......just dont let them frustrate you.
 

·
Registered
Joined
·
307 Posts
I might not know what i'm talking about but didn't the 03 have a recall on the pig tail for the icp sensor I've heard that some where before You probley are way ahead of me but i thought i'd throw it in
 

·
Registered
Joined
·
119 Posts
Its not a recall but a TSB is out for that concern.
 
1 - 9 of 9 Posts
Top