Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Premium Member
Joined
·
6 Posts
Discussion Starter #1
I changed the fuel filters on Saturday night and after a little coaching drove it all day Sunday. Killing it several times. This afternoon I went to leave and it will not start at all. It will turnover, but acts like it isn't getting fuel. Any ideas?
 

·
Premium Member
Joined
·
1,064 Posts
Did you use motor craft filters? There are several post on here about using motor craft fuel filters. I would pull off the filter on top the motor and see if you are getting fuel there. May be before the 2nd filter. Keep us posted
 

·
Premium Member
Joined
·
6 Posts
Discussion Starter #3
No I did not use motor craft fuel filters. Normally I would, but the dealership was closed and the little auto parts store in town doesn't carry them. The filters may be the problem, but its odd that it worked really well yesterday after I changed them. I did pull the top filter and it had fuel in it, so I'm not sure. Everytime I turn the key and try to start it, it acts like it wants to start and a few times it has, but shakes pretty bad then dies. Not sure if I need to change the filters again to motor craft, or if maybe the fuel pump decided to take a dump or if it may be injectors.
 

·
Premium Member
Joined
·
1,064 Posts
That sucks. It is pretty easy to change a ficm. Hopefully the dealer didn't rape you. I'm glad you got it figured out.
You might want to have your batteries load tested. You can take it to any parts store to have that done. Maybe check your altenator while your at it. Good luck
 
1 - 6 of 6 Posts
Top