Ford Powerstroke Diesel Forum banner

21 - 34 of 34 Posts

·
Registered
Joined
·
208 Posts
bad injectors like my truck? mine did the whole running rough, surging, rough idle, no power on start up till the truck got warm etc.
 

·
Registered
Joined
·
11 Posts
Whats up guys. My truck started doing the same thing as yours recently. Except this is the 2nd time around for me. The first time I took it back to the dealer because it was under warranty. They replaced the ICP sensor on the valve cover, the exhaust back pressure sensor, both turbo tubes, the connectors that go to the 2 sensors, and re-routed some wiring for the FICM.
I replaced the cam sensor and no luck. I'm gonna try to clean the EGR vavle tomorrow and see what happens. I'm not getting any codes or a light and best I can tell everything looks normal on my scanner.
 

·
Registered
Joined
·
1 Posts
rough idle

mine is doing the same, change filters last week. Only 50,000 miles on the engine, someone mentioned draining the oil/water separator, how is this done?
 

·
Registered
Joined
·
283 Posts
check your wiring harness to the ficm, it will become chaffed and wires can become exposed, my truck has this problem and im waited on a warm day or a spot in the heated shop to fix it
 

·
Registered
Joined
·
84 Posts
My truck started something similar today...Its intermitant.. it starts fine....idlel is ok...but when it try to pull away from a stop it chugs for 1k to 2k and pours out black smoke than it takes off like hell...shifts gears and seems ok but if you back off on the throttle it does the same thing again...every now an again it pull off the line fine...i figured i got some crap gas or pulled something from the bottom of the tank...put some fuel clener in...but no change as of yet
 

·
Registered
Joined
·
39 Posts
I also have the same problem with my truck 06 PSD F350. 2 different Ford dealerships said nothing was wrong and sent me on my way. I still cant figure out what the problem is.
 

·
Registered
Joined
·
2 Posts
Same miss

I have recently purchased a 05 with the 6.0.It had bad miss as everyone seems to be having.Took it to ford and they reflashed the commputer with a update.It is much better but still has the miss when cold.Took it to a deisel shop and they said nothing is wrong.It is normal for the 6.0 to do this.
What is up with this.I wish i still had my 7.3.
 

·
Registered
Joined
·
1 Posts
I have a 04 f250 with a 6.0 and my truck is not firing on cyliners 1 3 5 and 7. The truck will start and run for about 5 minutes on the 4 working cylinder and then start clicking really loud and then choke out and die. It will restart after sitting for about 10 minutes. Do any of you guys have any information for me?

Thanks.
 

·
Registered
Joined
·
3 Posts
Rough, choppy idle, no power till it warms up.

I had a lot of the same symptoms. My truck would be hard to start when it was cold. Once it started it surged and idled choppy till it warmed up. It had no power till it warmed up. Bearly drag its own ***. Being out of warranty I started looking for a solution. After reading a lot I was suggested to replace the FICM. I took the truck to my friend and he scanned it and there were cyl contribution codes, cam position sensor codes, injector circuit low codes, ect. He said i might have injector problems but ide have to replace the FICM first. I took a gamble and bought a used 2003 ficm and the truck fired right up. No more surging or caughing. All the pwr in the world. I have noticed a slight injector stiction but that goes away in like 2 blocks of driving and doesnt return till the next time the truck starts cold. No more codes coming up on the scanner. Also, some people said they took their truck to ford and they reflashed the computer. They are using a new tune that has inductive heating properties. This cycles the injectors to help heat the spool valves up to aid with cold starts ect. That flash will eventually kill your FICM. THat is what happened to mine. The new FICM i have is original to the 03 6.0 it came from and hasnt been reflashed. There is also another down side to this programming.....you loose some power and about 3 mpg. Now i have all my power back and my mileage too. Just thought ide let you all know. You can bet the FICM flashed back to the old tunes but it has to be done by a custom company like Spartan. Ford dealers wont reflash them backwords. Also the FICM's are weak so i dont recomend the hot box mod.
 

·
Registered
Joined
·
2 Posts
I have a 04 f250 with a 6.0 and my truck is not firing on cyliners 1 3 5 and 7. The truck will start and run for about 5 minutes on the 4 working cylinder and then start clicking really loud and then choke out and die. It will restart after sitting for about 10 minutes. Do any of you guys have any information for me?

Thanks.
I had this happen after i replaced injectors 1 3 6, new injector failed nd was allowing compression to push back through the fuel system
 

·
Registered
Joined
·
1,618 Posts
my 06' 6.0 will idle rough when i come to a stop occasionally n shake the whole truck and sometimes arnt as bad as others is it the ficm?
This is a symptom of a fueling issue. Doesn't have to be fueling, but a major symptom of it....
It's very common to have problems with the pick up foot in the fuel tank getting clogged up, could be plugged up filter, hfcm or, even, a failing fuel pump.
You should have a fuel pressure gauge installed, so you can watch fuel pressure.

Sent from my Redmi Note 9 Pro using Tapatalk
 
21 - 34 of 34 Posts
Top