Ford Powerstroke Diesel Forum banner

1 - 20 of 34 Posts

·
Registered
Joined
·
1,228 Posts
Discussion Starter #1
I have a 2004 f-350 with the 6.0. My truck has been been like missing or something like its been cutting out when at an idle and it like shakes the whole truck and even sometimes even dies. Its not giving any codes or anything. And i have my egr unplugged. So any help greatly appreciated. Thanks alot!!!!
 

·
Registered
Joined
·
1,392 Posts
Bump

Ken....
 

·
Registered
Joined
·
1,479 Posts
Have you changed fuel filters recently? Perhaps they're due?
 

·
Registered
Joined
·
4 Posts
My 05 was doing the same thing but I would sometimes have a dead go pedal. I know it sounds dumb, but I unpluged the harness going to the go pedal and plugged it back in and I haven't had the problem in 2 weeks. I have adj. pedals and maybe it got loose some how.
 

·
Registered
Joined
·
19 Posts
My 05 was doing the same thing but I would sometimes have a dead go pedal. I know it sounds dumb, but I unpluged the harness going to the go pedal and plugged it back in and I haven't had the problem in 2 weeks. I have adj. pedals and maybe it got loose some how.
Have the same problem with my 04psd. Change fuel filters, drained the water separator, cleaned the egr no changes. I tried disconnecting the electrical plug above the gas pedal and reconnected. Hopefully this will take care of it. Didn't get a chance to test it this evening, I will tomorrow.
 

·
Registered
Joined
·
19 Posts
Truck still doing the same thing. Does anyone have any idea if the TPS, throttle position sensor, is covered by the extended warranty. How much are they?
 

·
Registered
Joined
·
46 Posts
I have a similar problem, maybe the same thing. My truck is an o6', only mod is an after cat exhaust. The truck will sometimes idle rough, as if it were not getting fuel or something. It fluctuates in idle a couple hundred rpm's or so ie: updownupdown etc. If I rev it up a couple times, it clears away and idles properly. The truck is new, I've only logged 12,000 miles on it. Ford say'sif there's no check engine light, there's nothing they can do unless it happens while Im at the dealership.
 

·
Premium Member
Joined
·
649 Posts
My 04 did the same thing. At first I was changing my fuel filters every 15K and the problem eventualy got so bad that it would die at a red light. Problem solved when I started changing every 7.5k along with oil. I also quit using cheap filters to. Im now using wix and have been trouble free for 30K.
 

·
Registered
Joined
·
232 Posts
Mine started missing really bad, would die and not start back until the engine was cold again. It was my HPOP, I hope it something cheaper and more simple than the HPOP for you. Mine wasn't throwing codes either.
 

·
Banned
Joined
·
0 Posts
First of all is the miss only on a cold start? The newest ford reflash will cure that...

The miss could be a lot of things, injectors and the ICP sensor or connector are the most common....other causes could be the APP sensor, chafed wiring harnesses, and a host of other things...

check for codes first.....
 

·
Registered
Joined
·
46 Posts
No not on a cold start for me. It's not really a miss. It's more like a surging in the idle, up and down in the rpm's a bit. Sorta like bad fuel or filters cloggged or running out of fuel. It hasn't happened for a while now. The truck has 12k miles and the dealer hasn't done the fuel filters yet, they're still original. Yesterday I drained the separator for the first time EVER! I filled up a small pint sized jar with what seemed like clean diesel. I let it drain until empty completely, is that accurate? I let it go until there was no more coming out.

I think with the new ULSD Fuel that it out there now, we're gonna see premature fuel filter clogging or wearing. Perhaps that is the problem. Im gonna change these filters every other oil change now as a rule of thumb. I will do it at approx. 7500 miles both top filter and bottom. Also, I do use Lucas every once in a while in the tank.
 

·
Registered
Joined
·
19 Posts
had the dealer replace the egr and reflash. Still have the problem. Took it back and they replaced the EP (exhaust pressure sensor). We'll see if it works.
 

·
Registered
Joined
·
116 Posts
This sounds like the same problem I am having but mine has yet to die while idling. Guess I will check a few of the things already said. Keep us posted!
 

·
The Fat Mod
Joined
·
12,508 Posts
Yup, all of this sounds like what mine is doing. Glad I am not the only one so maybe we can get this figured out. Mine will surge so much, I have almost rear ended the car in front of me at a red light. Needless to say, I stop a lot further back now. I have less than 4K miles on the fuel filter. Not sure what the deal is. No codes either. Mine has died a couple of times, but it is usually a stumble and then revs to catch up. :dunno:
 

·
Registered
Joined
·
19 Posts
had the dealer replace the egr and reflash. Still have the problem. Took it back and they replaced the EP (exhaust pressure sensor). We'll see if it works.

Well after a few days of driving no PROBLEMS!!!! I think this did the trick.
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter #16
sorry i havent been keeping up but i changed egr still happening took top ford got reflashed still acting up. i will try the ep sensor and see what happens whats the cost of those and where is it???
 

·
Registered
Joined
·
258 Posts
My 05 is missing on a hot restart sometimes. I got a new turbo but it was no help. They dont seem to want to work on it anymore? Fuel filters only have 3000 on them and egr has been cleaned. I also lost about 3 mpg.
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter #18
hmmm i dunno i have done more reading im goinf to look into changing icp sensor
 

·
Registered
Joined
·
1,228 Posts
Discussion Starter #19
well thanks everybody for the input ordered an icp sensor sat they had it in today i oput it in and runs great. thanks everyone for your help!!!!
 

·
Registered
Joined
·
1,010 Posts
Mine is doing this aswell I will check my ICP sensor today. How much did it run you Smoke?
 
1 - 20 of 34 Posts
Top