Ford Powerstroke Diesel Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
Might be a bit late with this info for everyone but I've been having problems with my factory gauges in my truck here lately and from what I have been reading this is a common problem with the 6.0 trucks. I found a company called circuit board medics that rebuilt the entire cluster for 149 and warrenty them for life. I had the gauges back pretty quick and they work perfectly. I don't know if you or anyone you know are having problems with their gauges but this seems to be a low cost and effective way to fix a problem that seems common to our rigs without having to go through a stealership. They didn't change any of the faces or mess with data that it contains if your wondering.
 

·
War is the answer!
Joined
·
5,386 Posts
I was unaware that was common.

Sent from my SGSIII running a custom ROM.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #3
When mine started acting stupid my speedo was off by like 30mph and i jumped online and started looking for anyone else that was having the same problems and found a bunch of them. Just figured that I would pass along some info if anyone was having issues.
 

·
Registered
Joined
·
42 Posts
only problem ive had is my gas gauge going wonky from time to time
 

·
Registered
Joined
·
151 Posts
Might be a bit late with this info for everyone but I've been having problems with my factory gauges in my truck here lately and from what I have been reading this is a common problem with the 6.0 trucks. I found a company called circuit board medics that rebuilt the entire cluster for 149 and warrenty them for life.
I've been having problems with my speedo ever since I got it. Acts up in the cold weather. First time I have come across someone that may have an answer to my problem.
Thanks
 

·
Banned
Joined
·
976 Posts
I've been having problems with my speedo ever since I got it. Acts up in the cold weather. First time I have come across someone that may have an answer to my problem.
Thanks
Speed sensor in the rear axle. It's a 5 minute fix for most erratic speedo issues. At most stealerships, it's $90. Just did mine, went to local dealership, showed them it was $58 at some Ford dealers on-line, they sold it to me for $68. Sometimes you can just pull the sensor, clean it off and that's all it takes. My '96 full size Bronco had a very similar sensor in the axle, had to replace about every 3 years. It also serves a function for the ABS system in most vehicles as well as speedometer.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #7
soccerman I had the same issue with the speedo as you in cold weather and that was the reason I had them rebuilt. I tired the speed sensor replacement in the rear axle that rdezs described but it still was doing the same thing. So sent them out and once returned they have been working perfectly ever since. Hope the info helps out.
 

·
Supporting Vendor
Joined
·
181 Posts
I know that this is an old thread, but thank you for the reference. We have learned even more on the instrument clusters and want to be a resource to you guys to help you determine if the cluster is faulty. Many of the 1999-2007 trucks experience problems with the radio, power windows, and interior lights (dome light) not working properly, and the most common source of this problem is the instrument cluster. In the 2005-2007 trucks, there are also a lot of problems with the gauges sticking or reading incorrectly.

Repair service for 99-04 Super Duty Trucks:1999 - 2004 Ford Super Duty Instrument Cluster Repair | CBM

Repair service for 05-07 Super Duty Trucks: 2005-07 Ford Super Duty Instrument Cluster Repair | CBM
 

·
Administrator
Joined
·
22,089 Posts
Welcome, and glad to have you... tread lightly as you are not a sponsor... yet :D

PowerStroke.org Supporting Vendors The supporting vendors in this section have made a commitment to the community and help support this website. Please consider using a supporting vendor for your future purchases and support the vendors who support you. For information on becoming a supporting vendor, please send an email to [email protected]
 

·
Registered
Joined
·
182 Posts
Discussion Starter #10
They definitely need to get on the sponsor thing, I've sent like 3 other guys locally to them with good results, the fourth turned out to be a abs block issue.
 
  • Like
Reactions: CircuitBoardMedics

·
Premium Member
Joined
·
969 Posts
This is great info I was unaware of. Glad it got revived to know about this problem and the company who can fix it
 

·
Registered
Joined
·
953 Posts
Perfect timing. My speedo went nuts last month during a normal cruise...it was like 40mph off. Did it for a couple days, then went back to working fine. Checked speed with GPS and speedo is on target. I may have to sent my cluster to these guys. Thanks for the info.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #13
Not all cluster issues the cluster has are at the cluster itself. There are other issues that may cause the cluster problem imho. My issue was cold mornings the stepper motor for the speedo was causing it to stick and be 40-50mph off. I tried the whole list of crap it could be and none of it worked, some trucks it did mine not so much. My buddies 04 had a abs block issue that killed the speedo. I just wanted to pass on information that might be helpful and a way to fix it without the stealership having people buy a new cluster for no reason. This is all just my .02
 

·
Supporting Vendor
Joined
·
181 Posts
We are in the process of working with the site administrator to sponsor the site, so I'll try to "tread lightly" until we are an official sponsor. I don't want to sound like we are pushing our services here, but I do want to help you guys diagnose the gauge/cluster problems further.
We rebuild a lot of clusters that cause a loss of power windows, radio, interior dome light, etc. We also rebuild a lot for sticking/erratic gauges. The instrument cluster will also cause a false low fuel condition causing the fuel gauge to read empty and the low fuel warning to come on. Unfortunately there is no short list of "common failures" with the clusters, and Ford uses them like a second processor in these trucks. They control a lot of different features of the truck, and gone are the days of swapping them out with another from the salvage yard.
Let me know if we can help you troubleshoot the cluster. We're here to help!
 
  • Like
Reactions: Heavy_GD

·
Registered
Joined
·
2 Posts
We are in the process of working with the site administrator to sponsor the site, so I'll try to "tread lightly" until we are an official sponsor. I don't want to sound like we are pushing our services here, but I do want to help you guys diagnose the gauge/cluster problems further.
We rebuild a lot of clusters that cause a loss of power windows, radio, interior dome light, etc. We also rebuild a lot for sticking/erratic gauges. The instrument cluster will also cause a false low fuel condition causing the fuel gauge to read empty and the low fuel warning to come on. Unfortunately there is no short list of "common failures" with the clusters, and Ford uses them like a second processor in these trucks. They control a lot of different features of the truck, and gone are the days of swapping them out with another from the salvage yard.
Let me know if we can help you troubleshoot the cluster. We're here to help!
I am having these issues as well and had already visited your site before joining this form. I plan on sending my cluster in this week but have a question. The message center is also giving me readings for faulty trailer issues and water in fuel (I have no water in fuel for sure) and the trailer faults will even happen with the trailer unplugged until you restart the engine. I am also blowing the fuse for my High Beam lights. Can any of these issue be caused by a faulty cluster? :dunno:
 

·
Supporting Vendor
Joined
·
181 Posts
It sounds like you have a few different issues going on outside of the cluster. What specific messages are you seeing on your information display regarding the trailer? It may be your integrated trailer brake control module that is faulty. We have repaired the trailer brake controller for different kinds of crazy behavior.
The water in fuel message that you are seeing could be a dirty sensor. There is a sensor on the fuel filter housing that is underneath the cab (the larger of the two fuel filters). You can often clean that sensor with a good contact cleaner, and clear the nuisance warning.
Blowing the fuse for the high beams has me stumped. Hopefully someone else can chime in with experience with that happening.

Here are the links for the cluster repairs:
1999-2004 clusters:
1999 - 2004 Ford Super Duty Instrument Cluster Repair | CBM

2005-2007 clusters:
2005-07 Ford Super Duty Instrument Cluster Repair | CBM

As always, feel free to contact us at 800-547-2049 as well. I look forward to serving you.
 

·
Registered
Joined
·
2 Posts
If I am not mistaken it just says Trailer Fault check trailer and the trailer breaks don't work and the trailer box flashes. Then they will start working again and go out again. The trailer and breaks work fine on my 2012 f 250.
 
1 - 18 of 18 Posts
Top