Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
420 Posts
Discussion Starter #1
so last night was racing this carmao and on my way back from racing him i was doing like 35MPH and my truck started to idle rough and then it shut off lucky i was able to coast into the parking lot looks like a quart of oil maybe a little more leak out then it stop then it was smoking a lil bit from the hood pop the hood to relase all the smoke but i think cuz the oil got onto the exhaust thats why not sure though truck wont start the rear main seal was leaking a lil bit before all of this earlier today... Did i blow the rear mean seal out? anyone with any advice would be awesome
 

·
Registered
Joined
·
420 Posts
Discussion Starter #3
Well i went out today and hook up the computer to id not DTC but its not building enought ICP its only at 45PSI and this morning I went out there and another quart or so seem to leak out. coolant level full i know the HG are goood no oil coming from there. I looked in the motor bay and didnt really see to much going on. I put silicone around the rear main but i can only get it around half way so i couldnt get it on top.... I want to say the rear mean seal went and its leaking from the top and dripping down....
 

·
Vendor
Joined
·
1,594 Posts
It would be a strange occurance to "blow out" a rear main. If thats the case, you have some internal engine damage as the bottom end pressure should be minimal. High pressures would be created by excessive blow by, a hole in a piston, etc. I would venture to guess that it is something on top of the engine valley that is running down the back of the block and making it appear like its coming from the rear main. Check your high pressure oil lines and see if one blew and check all the other lines around the valley area. Keep us posted on what you find so we can help further
 

·
Registered
Joined
·
1,712 Posts
Check to see if your IPR valve blew out. It's under the turbo on the drivers side mounted to the HPOP. I'm not sure if it could leak enough oil to kill your HPO pressure that much, but it's possible. Have you ever had the STC fitting replaced on your truck. They were notorious on 05's for coming loose or breaking off at the HPOP, but that's an internal thing.
 

·
Registered
Joined
·
420 Posts
Discussion Starter #6
Check to see if your ICP sensor blew out. It's under the turbo on the drivers side. I'm not sure if it could leak enough oil to kill your HPO pressure that much, but it's possible. Have you ever had the STC fitting replaced on your truck. They were notorious on 05's for coming loose or breaking off at the HPOP, but that's an internal thing.

Yeah that what i was thinking to.. I know the STC fitting can break i know i never swap them out so my guess would be that that piece may have broke and a metal shaving got into the IPR sensor and shut the valve on it so that why its only getting 45 PSI ( This has happen to me twice before with this IPR valve)... iam bringing to buddy garage on tuesday iam going to remove the turbo and pedstole and the y pipe to the exhaust manifolds to see whats going on back there. I diff want to know why its leaking like that it tends to leak a quart or so then stop then leak again and stop
 

·
Registered
Joined
·
420 Posts
Discussion Starter #7
update.....So got the truck to the shop and wasnt leaking anything ever since i did headgaskets on it every oil change i have had to put in 16QTS to be at the max mark....anyways pull the turbo and the IPR valve it seems to be in good shape all the srceens are good and gaskets on it are good... well i took off the y pipe assembly and notice a oil spot on it like something exploded on it and i got my head in there and notice that on the back of the passenger head was a freeze plug that looked to me it had oil around it like thats where it was leaking from... Has anyone ever heard of that? I got my ford buddy who works at the dealer looking at it tomorrrow.. soo will see how that goes
 
1 - 7 of 7 Posts
Top