Ford Powerstroke Diesel Forum banner

37221 - 37227 of 37227 Posts

·
Mr. Crossthread
Joined
·
4,566 Posts
He should lurk louder, we miss him. Lol

Sent from my SM-A505U using Tapatalk
 

·
Registered
Joined
·
1,607 Posts
Hey guys, quick question. My truck has a shimmy like it's out of alignment and I've been trying to chase it down for a while. I have new ball joints, wheel bearings, rotors, shocks, and tires, but its still there. I got an alignment and the individual front corners are all in the green, however the cross caster is in the red (cross camber and total toe are in the red). The cross caster is at -0.9 and the specified range is at -0.6 to 0.6. The front left caster is at 1.3 and the front right caster is at 2.2, the specified range is 0.5 to 3.1. Do you think the cross caster is causing the issue? At this point I'm out of ideas. I know I need a new steering gear box and my steering stabilizer is probably not doing anything but I don't think that would cause this shimmy.

768825


In slightly better news, my bumper has arrived. Not sure if I like the red tow hooks, but they were only $25 from Amazon and might match the theme on the truck. I didn't know if the lights I had would work so I only put the one in but it looks decent so I ordered another set.

768824
 
  • Like
Reactions: john galt and ZMANN

·
california deplorable
Joined
·
10,710 Posts
This is being done in the name of shenanigans, its more to poke fun at whos truck it is than anything


Sent from my iPhone using Tapatalk
I figured....still a heck of a color, my wife would love it 🤣
I just painted mine too, but I'm boring all I had was gloss black

Sent from my SM-S727VL using Tapatalk
 

·
california deplorable
Joined
·
10,710 Posts
Hey guys, quick question. My truck has a shimmy like it's out of alignment and I've been trying to chase it down for a while. I have new ball joints, wheel bearings, rotors, shocks, and tires, but its still there. I got an alignment and the individual front corners are all in the green, however the cross caster is in the red (cross camber and total toe are in the red). The cross caster is at -0.9 and the specified range is at -0.6 to 0.6. The front left caster is at 1.3 and the front right caster is at 2.2, the specified range is 0.5 to 3.1. Do you think the cross caster is causing the issue? At this point I'm out of ideas. I know I need a new steering gear box and my steering stabilizer is probably not doing anything but I don't think that would cause this shimmy.

View attachment 768825

In slightly better news, my bumper has arrived. Not sure if I like the red tow hooks, but they were only $25 from Amazon and might match the theme on the truck. I didn't know if the lights I had would work so I only put the one in but it looks decent so I ordered another set.

View attachment 768824
Shiny like a vibration? Might sou d weird but Jack up the front end and line up the axle u joints and see if the wheel moves on both sides of the u joint. If that makes any sense?
Logged 240 miles in the truck today. Man I love that thing

Sent from my SM-S727VL using Tapatalk
 

·
Mr. Crossthread
Joined
·
4,566 Posts
Shiny like a vibration? Might sou d weird but Jack up the front end and line up the axle u joints and see if the wheel moves on both sides of the u joint. If that makes any sense?
Logged 240 miles in the truck today. Man I love that thing

Sent from my SM-S727VL using Tapatalk
Less lag and better response? Notice any mileage difference?

Sent from my SM-A505U using Tapatalk
 

·
Premium Member
Joined
·
2,206 Posts
Kinda 6.0 related (we had to drive it to get there :cool: )! LOL

My spot for the day till the tide runs out. Plunking for salmon with my girls. They're already digging to China with their shovels :)

Heeeeeeeere fishy fishy fishy.

768830

20200807_095214.jpg

-jokester
 
37221 - 37227 of 37227 Posts
Top