Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
My truck started smoking a lot this past month when I get on the throttle. There is a lag until the turbo spools up and then I get power but until the turbo spools I smoke like a train without any power. (3-4 seconds of a whole lot of black) Is it the summer temps causing this or do I need to reload the tune? Running the 275 version 3 and I've never even loaded the other tunes. Does version 4 remedy this by chance?
 

·
Premium Member
Joined
·
8,819 Posts
Try reloading. The v4 could help, but it is rail pressure fix tune. It's a free tune though, so it would be worth it to get it anyway. You should not have that much turbo lag....hear does make the smoke thicker for sure, but I wouldn't think it would cause that much turbo lag...
 

·
Premium Member
Joined
·
375 Posts
My truck started smoking a lot this past month when I get on the throttle. There is a lag until the turbo spools up and then I get power but until the turbo spools I smoke like a train without any power. (3-4 seconds of a whole lot of black) Is it the summer temps causing this or do I need to reload the tune? Running the 275 version 3 and I've never even loaded the other tunes. Does version 4 remedy this by chance?
With the less dense air we are all adding more unburnt fuel in the warmer months, thus more smoke....

Definitly try a reflash or an upgrade.

Mike
 

·
Registered
Joined
·
35 Posts
Mine did the same thing and it didnt matter what tune it was on or even stock turned out i had a broken egr ford replaced and all is well
 
1 - 4 of 4 Posts
Top