Ford Powerstroke Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all. Bill here. I am new to this forum.
2017 F350 6.7.
A/C started blowing hot (ambiant) air on all a/c settings.
I see the clutch was not activating.
Engine off, unplugged the clutch, shot 12v to the clutch, clutch activates.
Engine on, 12v Direct to the clutch, clutch activates, turns compressor, cold a/c.
It appears the compressor works as it should, blows cold indicating proper refrigerant pressures, clutch will activate.
It seems to be a lack of communication to the a/c clutch telling it when to activate off and on.
Fuses 3 and 16 are good.
Am I missing something. Has anyone else run into this problem.
Thank you in advance for any and all comments and information with this.
Bill
 

·
Premium Member
Joined
·
11,851 Posts
Have you checked for codes?
Just because it cools when the compressor is manually activated, doesn't mean there's sufficient refrigerant in the system to kick the low pressure switch out. Lower pressure will generally cool better, to a point. That's why the low pressure switch is there in the first place. If the refrigerant volume is too low, the system will ice over.
 

·
Registered
Joined
·
3 Posts
Hey all. Bill here. I am new to this forum.
2017 F350 6.7.
A/C started blowing hot (ambiant) air on all a/c settings.
I see the clutch was not activating.
Engine off, unplugged the clutch, shot 12v to the clutch, clutch activates.
Engine on, 12v Direct to the clutch, clutch activates, turns compressor, cold a/c.
It appears the compressor works as it should, blows cold indicating proper refrigerant pressures, clutch will activate.
It seems to be a lack of communication to the a/c clutch telling it when to activate off and on.
Fuses 3 and 16 are good.
Am I missing something. Has anyone else run into this problem.
Thank you in advance for any and all comments and information with this.
Bill
Hi Bill. What'd you find out with this?? Mind just started doing that same thing....
 

·
Registered
Joined
·
3 Posts
Hey all. Bill here. I am new to this forum.
2017 F350 6.7.
A/C started blowing hot (ambiant) air on all a/c settings.
I see the clutch was not activating.
Engine off, unplugged the clutch, shot 12v to the clutch, clutch activates.
Engine on, 12v Direct to the clutch, clutch activates, turns compressor, cold a/c.
It appears the compressor works as it should, blows cold indicating proper refrigerant pressures, clutch will activate.
It seems to be a lack of communication to the a/c clutch telling it when to activate off and on.
Fuses 3 and 16 are good.
Am I missing something. Has anyone else run into this problem.
Thank you in advance for any and all comments and information with this.
Bill
hey bill any luck on this issue my 2017 is doing the same thing first started intermittently now nothing
 
1 - 8 of 8 Posts
Top