Ford Powerstroke Diesel Forum banner

1 - 20 of 40 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1 (Edited)
I did not find any threads that talk about doing a full audio upgrade on the 2013 and up trucks with Navigation. So I figured I will make a contribution to the group and create a thread on my build.

I am not doing this build myself. I came up with what all I wanted and how I wanted it done and it is being done by a buddy of mine who is a professional installer.

Game plan:

The head unit, will remain the same. No changes all the way to the factory Sony amp. Basically disconnecting the factory amp is not an option as if you disconnect the factory amp, the sync goes blank and nothing comes up.

So will use a Bit Ten processor from the factory amp on-wards. Plan is to keep all the factory wiring untouched so if I ever have to put it back to factory condition it is pretty much plug and play.

It will be a passive set up. I do not want to spend the money to get an active setup.

The front door will get Dynamat inside out. The rear doors since don't have any mids will only get dynamat on the outside skin. The rear part under the rear glass will fully dynamated.

Equipment:
Processor / Line output converter: Audison Bit Ten processor
Amplifier: JL Audio HD 900/5
Front stage: Focal 6.5" KR component speaker system
Rear: Focal 6.5 coax speakers.
Subwoofers: Pioneer 10" Shallow mount X 2 in a custom box.
 

·
Registered
Joined
·
145 Posts
Subscribed

Good job!
 

·
Registered
Joined
·
4,330 Posts
Nice work. I didnt know you could pass wires through the door like that. thats awesome. I been wanting to do a speaker swap in my truck but is there much improvement without adding an amp?
 

·
Registered
Joined
·
144 Posts
Discussion Starter #7
Yes you will definitely see an improvement if you change the speakers probably not as much as adding an amp though. I would not do just the speakers because the improvement is marginal, but again I have never tried to run an high end component speakers on factory amp either, so no idea how much more improvement that would bring.
Will post a pic of my processor and amp set up in the evening. The sub box and subs should be installed by Thursday so will post pics of that by Friday or so. So far I have found one issue with the Bit Ten processor that is related to auto sensing feature so will try to resolve that with the installer this week.
 

·
Registered
Joined
·
179 Posts
I did a similar install in another thread. New JL door speakers, ran new speaker wire through molex. In lieu of driling them, I heated up a small pick and melted my way through the plastic in an unused terminal. Driver side has a ton of wires, passenger side is more open. New JL amps, new 13Tw5 sub. I didn't to any mat yet, but I might get around to it. there are some rattles in the ceiling around the upper console or inside the rear view mirror. Crap in door pockets vibrates too.
 

·
Registered
Joined
·
4,330 Posts
although you said you had a factory amp which i dont believe I do with just an XLT. I was looking to buy some focal components and run them on my factory head unit. with mine being a reg cab i dont have much room as it is especially to be mounting amplifiers and what not.
 

·
Registered
Joined
·
179 Posts
although you said you had a factory amp which i dont believe I do with just an XLT. I was looking to buy some focal components and run them on my factory head unit. with mine being a reg cab i dont have much room as it is especially to be mounting amplifiers and what not.
I'm sure you could find a spot for an amp. They are fairly small compared to amps in the old days.
 

·
Registered
Joined
·
4,330 Posts
I'm sure you could find a spot for an amp. They are fairly small compared to amps in the old days.
oh yeah there is room, I was just wanting to keep the little space I have. can you use one amp and get a little sub and run doors and sub off one amp or do you need two seperate amps?
 

·
Registered
Joined
·
179 Posts
oh yeah there is room, I was just wanting to keep the little space I have. can you use one amp and get a little sub and run doors and sub off one amp or do you need two seperate amps?
You can run a 4 channel amp and use the front channels for the door speakers and bridge the rear channels for a sub. Fairly common.
 

·
Registered
Joined
·
144 Posts
Discussion Starter #13 (Edited)
I am only using one amp as you can see in the first post. Here is the progress pics of the install.



Focal crossovers mounted right below the amp on the specially made carpeted board.



Audison Bit Ten sits on a board that goes over the crossovers



All cleaned up after the seat goes in:



Found the use for this little hole: Bass nobe

 

·
Registered
Joined
·
4,330 Posts
Looks super clean!
 

·
Registered
Joined
·
192 Posts
Good looking install. Did you use the wires (constant power, enable/clip) from your stock sub or did you run new wires?
 

·
Registered
Joined
·
144 Posts
Discussion Starter #16
Good looking install. Did you use the wires (constant power, enable/clip) from your stock sub or did you run new wires?
Not sure I follow your question. If you are talking about the power to the amp: It has to be run from the battery. The amp wakes up by the way of Audison. Audison wakes up when it senses power from the speaker wires that are clipped to feed Audison after the factory Sony amp. Hope that helps.
 

·
Registered
Joined
·
144 Posts
Discussion Starter #17 (Edited)
The system install is now complete and happy to report it has met all my requirements and expectations. The installer did an amazing job of tuning the system as well and thus it sounds awesome.

Here are couple pics of the sub-woofer box installed.





Love the look of the yellow speaker thru the grill.....



Because of the flash you can see the little silver from Dynamat but generally that is not visible. Had to seal the speakers well so that is why the dynamat is there.
 

·
Registered
Joined
·
255 Posts
Great install. I bet it sounds awesome! Question, how was your amp board fastened to the wall of the cab? And did the jack have to be moved or is it in a different location for the 2011+ trucks? I have a 2010 crewcab

Sent from AutoGuide.com Free App
 
1 - 20 of 40 Posts
Top