Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Wondering if anyone can confirm that I need a new tcm?
situation; drove home, everything fine, go outside to move my truck, no start, cycle the key two times with foot on break, truck starts. Advance track service light, engine light, wrench light, no gear indicator light, no action from trans gauge. Truck shift somewhat hard into reverse and will only stay in 4th or 5th while in drive. Hooked up tuner, took a minute but then threw U0101 code. I understand that the tcm is clearly not communicating. I run sct x4 tuner, have for over 40,000 miles, never an issue before. Read a few posts about 6.4s having same issue. I’m assuming it is a dead tcm from what I can gather off of other posts, but would like to hear some input before I buy one. Thanks
Truck is deleted, aftermarket exhaust manifolds, aluminum inter cooler piping, intake, 5 in exhaust, tuned
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Update, started the truck and everything appeared to be communicating the way it should, then it threw a P0884 code (sct tuner says, tcm power input signal intermittent) while driving it around the neighborhood. Very erratic shifting, tcm communication comes and goes, engine light come and goes almost like there is a wire(s) not making good connection. Looked around the tcm for bad connections, damage, chafing. Nothing I can see. Little lost on what the hell is going on at this point.
 
1 - 2 of 2 Posts
Top