Ford Powerstroke Diesel Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
2008 F350 Ambulance 6.4L with 102,400 miles...YEP....Now Dead.

I bought this ambulance at 88,000 miles. Seemed to be serviced regularly. Had good records. Truck had HPFP replaced 16,200 miles ago (says my dealer now via history with Ford..Oasis or something like that). Upon buying truck immediately did complete service, fuel filters, oil, checked for water etc. All seemed good. Put truck in service. Truck had intermitent trouble of what seemed like a misfire. Sent truck to local dealer at about 93k miles for misfire and puffing white smoke in excess out exhaust on occasion and they said PCM needed flashed....sent truck back to us in 2 days "fixed". Truck didn't misfire anymore but we would still see smoke at times. Spoke to service manager at Ford dealer again and they said send it in if it throws a code. No code or engine light. Continued to use truck. We also have a daily written log of check of fluids and everything seemed good.

One week ago truck was running fine at 9am. Crew turned truck off and two hours later upon receiving an ambulance call, the crew went to start truck and it would just spin over, would not start. Acted like it wanted to start about every 3 seconds but wouldn't. Had towed to dealer. Dealer said checked it out and said no fuel pressure...0 to 300 psi at best....out of warranty by 2400 miles. Wanted to pull valve covers, pull injectors and do some type of pressure or leak test (not exactly sure), then depending on that replace the HPFP. I opted to have vehicle removed from dealer and taken to a reputable not Ford dealer who many local companies have moved towards. The owner is a 12 years Ford certified tech. He looked at truck and did a compression test (he had a little different phrase) and while doing the test it actually started...his computer said injector 7 had mechanical failure and he said it was throwing fuel straight out exhaust. He called said replace injector 7. I gave ok. Further testing showed no compression on 7 and 2....I think he said dead cylinder.

Now with injector 7 replaced and then it wouldn't start again. He said unfortunately he believes HPFP again but might be more serious problem in short block. He ask again..."are you sure it was running fine" and my answer was FOR SURE..only because i put my eyes on it that morning. I gave ok to replace HPFP, he pulled exhaust off turbos and they were BLACK BAD...lots of buildup. He also had coolant in exhaust. This concerned him seriously so he stopped and called me.

Between him and I discussing it we believe we have complete engine failure. Obvious fuel system issue but we could put 4-6k into that and fix it. Obvious issue with coolant in exhaust (right????) and two cylinder issues. I have a non local dealer willing to sell me a turn key 6.4 for $10,900 but my gut tells me 16k miles ago a HPFP and me having it at a FORD dealer before the warranty expired for a misfire and blowing smoke and nothing really fixed other than PCM that I have an arguement with FORD....

So the big question is can I get a warranty covered at 102,000 miles on a problem that was probably going on before the warranty expired and I had in a dealer for it. Or am I stuck with an out of pocket repair? My dealership is ticked I pulled the truck....so can I somehow argue with Ford direct? How do I do that. Can anyone on here help me pull details from Oasis or whatever that system is so I have EVERY piece of history on this truck? We could use the help...our newest unit is DOA.

 

·
Registered
Joined
·
334 Posts
All they can say is no. I would call Ford, you had it in for these problems and nothing was really solved. I would give it a try. I love Ford trucks, even being a GM guy, but if I was at 102,000 and the engine blew for a known failure, injectors, HPFP, etc. and Ford did not cover, it would be my last one.
 

·
Registered
Joined
·
1 Posts
Similar Problem

Hey, What ever came of your dead 2008 F-350? I have a real similar problem. The truck was driving just fine, turned it off, now I am being told I need a new motor!! Really hoping you found out some good news!
 
1 - 3 of 3 Posts
Top