Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
New to this forum but I am having an issue with my truck. 2008 F250 / 6.4L with 115,000 miles. I have an H&S programmer, DPF/EGR Delete. Check engine light came on with P0607 code on the transmission. The truck runs fine, but will have a hard shift (almost like it was in neutral before it shifted) from 2nd to 3rd under a load (Not all the time). I have checked the batteries, connections, ETC. When it is in gear, no slipping or anything out of the ordinary. Ford Obviously wants to install a new tranny, however, I don't think that's the problem. Any help/guidance is appreciated.
 

·
Registered
Joined
·
178 Posts
The code comes up as an pcm code have you gone back to stock tuning to see if problem goes away?

Randy
 

·
Registered
Joined
·
178 Posts
I had the same set up as you a few years back (08& h&s) and mine did the same also had a huge rpm leap between 2-3 so I returned it to stock then reinstalled the tune but left the trans alone worked great after that,sorry electronics and me don't mix well but I'm sure someone else will jump on here shortly.

Randy
 

·
Registered
Joined
·
273 Posts
I had the same set up as you a few years back (08& h&s) and mine did the same also had a huge rpm leap between 2-3 so I returned it to stock then reinstalled the tune but left the trans alone worked great after that,sorry electronics and me don't mix well but I'm sure someone else will jump on here shortly.

Randy
I have been getting this code lately as well. Truck seems to run and shift just fine. I can clear the code and it comes back in 1-2 drive cycles. It didn't start doing it until I had my Tap Shifter installed for a couple of months. However, I have disconnected it and the code still comes back. Just coincidence? Bad TCM?

Sent from my LG-H910 using Tapatalk
 
1 - 5 of 5 Posts
Top