Ford Powerstroke Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have an 07 F250 with almost 100k on the odometer. I've noticed coolant loss from my degas bottle over the last few weeks. I refilled it occasionally with about a gallon of coolant. It has put out white smoke twice. It was very little and then stopped. It's not an all time thing. My guess is that I have a slow leak in the egr cooler. I am thinking about buying the Bulletproof egr cooler because, I don't want to have a CEL on constantly with the egr delete. I know this a common problem for the 6.0. I also heard that changing the oil cooler too is recommended during this repair. I'm looking for any thoughts on this process from anyone who has had similar experiences. Is there anything else that I need to know before making this purchase? Thanks!


Sent from my iPhone using Autoguide
 

·
Premium Member
Joined
·
3,940 Posts
Is it wet around the coolant recovery bottle cap? I'm assuming that you do not have a tuner. Also, what is your EOT /ECT temperature spread?


Sent from my Autoguide iPad app
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
No, it isn't wet around the bottle. It doesn't have the white residue on it that some people have talked about either. Currently I don't have a monitor. I plan on purchasing an Edge CTS very soon though. The last time the truck was in the shop, the mechanic told me my oil pressure was inside operating perameters but, that it was lower than most he has worked on.


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
The stock gauges in the dash show all temps to be normal. It hasn't overheated according to them. I know it's hard to diagnose things without a tuner...


Sent from my iPhone using Autoguide
 

·
Registered
Joined
·
4,222 Posts
The latest TSB lists the new recomended coolant level to be approximately 1/4 inch below the min line molded into the tank. Are you overfilling it by any chance.
 

·
Registered
Joined
·
137 Posts
Probably just the EGR cooler.. It's pretty common. A simple delete will fix it. The white smoke is burning coolant. If its using that much, it's most likely the problem. Take off your EGR valve, on top of intake manifold by the intake elbow and see if it's wet. Should look like black frosting. Best way to tell.


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
I don't let it pass the minimum level on the bottle. Another reason I believe it's the cooler is I had some problems with loss of power and an exhaust code come up from an obdII read. I had the code cleared and that's when the white smoke began. That and I put a 5" turbo back exhaust on. Platinumdiesel, I would like to do the egr delete. That valve has caused me nothing but problems since I've owned the truck. I heard heard the 05-07's will have a CEL stay on if one is done. Have you heard anything different? I appreciate all the feedback guys.


Sent from my iPhone using Autoguide
 
1 - 7 of 7 Posts
Top