Ford Powerstroke Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
So I was about an hour from home with the wife and kids. Get back in the truck after it was shut off for about 20 minutes, and it took 4 long tries to start. Threw a code for low pressure in the high pressure oil. Ran absolutely perfect all the way home. Has not started since. SCT Livewire shows 285 psi sitting still, and builds little beyond that when cranking.
Now, when I was trying to start it, I noticed the oil pressure gauge was not going up. But then the truck started and the gauge went to where it normally does.

I pulled the IPR and the screen was completely gone. Like, it looks like it was never there to start with. Stuck an inspection camera in there, and there is no screen to be found. So I grabbed an IPR out of my other truck and tried. Still nothing. So I pulled the IPR and cranked it. Oil didn't even come out.

The oil pressure gauge is not climbing as I crank it. Pulled the LPOP regulator. Nothing clogging it up. I was afraid I ate a lifter and destroyed my LPOP, not to mention cam. So I pulled out the filter, depressed the plunger and cranked the engine. Housing filled right up. I dunno.

Why would I not read oil pressure if the LPOP seems to be working? Why would nothing be coming out of the HPOP? Why would it have started at all if there was some kind of oil feeding mechanical problem?

One other thing. When cranking, there is a "thunk" about once every second. Not a metallic sound or a knock. Almost sounds like an air valve closing under pressure or something. I have always noticed a similar sound when starting, but it would only do it once and then fire up. I had wondered if I was hearing the IPR being commanded once the ICP saw 500 psi, but it does it now with the IPR sitting on my bench.

Anybody have any idea?

If it matters, the truck has about 150k on it. I bought it with a blown head gasket about a year and a half ago, 10k miles. I put it together with studs, Warren 155/30s, a KC Stage 1, new OEM oil cooler, etc. High pressure system was barely touched other than what was needed to pull the heads.
 

·
Compression Ignition Addict
Joined
·
7,445 Posts
Let me guess ...... tall aftermarket oil filter cap w/ an OEM filter? lol
 

·
Registered
Joined
·
41 Posts
Discussion Starter #6
Quick recap, 07 6.0 always ran great. One day it started hard, but drove an hour home perfectly. Got it home and it wouldn't start. No HP oil, no base oil. Messed with the IPR, then found out about the oil filter cap. Swapped filter and cap.

So now I have base oil pressure. But I'm only getting about 380 psi in the high pressure system when cranking. I even pulled the ICP and cranked it a little to push the air out. Oil came out. Put ICP back in, no change in pressure, no start. Unplugged ICP, no start. So I guess I'm going to Home Depot to make an air adapter. But it doesn't make sense that I would have both problems at the same time. The IPR had no screen on it. Inspection camera says no screen stuck in the HPOP. So I swapped in an IPR from a running truck. No dice. One odd thing, I am getting a code for open IPR circuit on my original IPR, but not on the one from the running truck.
 

·
Registered
Joined
·
33 Posts
Whats your IPR duty cycle cranking while cranking?

Id put air to the hpop rail and listen. If you have to pull the valve covers and get a good light, crank it over and see if you can see any oil getting pushed by.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #8
Whats your IPR duty cycle cranking while cranking?

Id put air to the hpop rail and listen. If you have to pull the valve covers and get a good light, crank it over and see if you can see any oil getting pushed by.
I had to order the air adapter, it should arrive in a few days. I wonder if I popped the STC.
IPR goes straight to 85%
 

·
Registered
Joined
·
1,618 Posts
I bet you find a broken screen or bad orings on the ipr when you pull it.... Just a guess, but your going to pull it anyway.

Sent from my Redmi Note 9 Pro using Tapatalk
 
1 - 10 of 10 Posts
Top