Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Recently purchased an 05 with the 6.0 that had the transmission rebuilt less than 10k ago and turbo rebuilt with less than 5k on it. (I have all the documentation it was done at a diesel shop). Driving down the highway at 70 or so and it’s like it pulls itself out of gear and the majority of the time the rpm’s and boost drop. Occasionally it will rev up when it comes out. I let of the gas and within a second it goes back in gear and I can give it gas again. It is not all the time, I can go 100 miles down the highway and it will run just fine and then it will randomly do it. Might do it again in 15 seconds, might be another 100 miles or more. I took it to a local diesel shop as tow/haul started flashing after a bad episode of it. Don’t remember the exact code but it was solenoid C, monitoring tranny function after engaged. Tech stated, bad solenoid, failing solenoid body/gasket, or internal failure. So I ordered a reman solenoid body and gasket that came with all new solenoids. Installed it and no change. Finding it hard to believe internal failure when I can drive 100 miles or more straight with no issues one day and the next can’t get over 45mph because it keeps popping out. Please help!!! Any possible other options?
 

·
Registered
Joined
·
1,618 Posts
Recently purchased an 05 with the 6.0 that had the transmission rebuilt less than 10k ago and turbo rebuilt with less than 5k on it. (I have all the documentation it was done at a diesel shop). Driving down the highway at 70 or so and it’s like it pulls itself out of gear and the majority of the time the rpm’s and boost drop. Occasionally it will rev up when it comes out. I let of the gas and within a second it goes back in gear and I can give it gas again. It is not all the time, I can go 100 miles down the highway and it will run just fine and then it will randomly do it. Might do it again in 15 seconds, might be another 100 miles or more. I took it to a local diesel shop as tow/haul started flashing after a bad episode of it. Don’t remember the exact code but it was solenoid C, monitoring tranny function after engaged. Tech stated, bad solenoid, failing solenoid body/gasket, or internal failure. So I ordered a reman solenoid body and gasket that came with all new solenoids. Installed it and no change. Finding it hard to believe internal failure when I can drive 100 miles or more straight with no issues one day and the next can’t get over 45mph because it keeps popping out. Please help!!! Any possible other options?
Anything is possible, these are complicated machines..... Don't rule anything out because..... 1) it's been replaced or 2) it's expensive.
Do you know why the trans was replaced? Have you been replacing the filter regularly or at all.... And inspecting for "junk"?
It is possible that the original trans grenaded and sent "bits" through the (trans) cooling system and its clogging fluid flow. The remedy for this involves a new trans cooler and radiator, as well as getting the lines flushed.
MLAG (my lame *** guess).

Sent from my Redmi Note 9 Pro using Tapatalk
 
1 - 2 of 2 Posts
Top