Ford Powerstroke Diesel Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 · (Edited)
For the past few weeks I have had a few issues with the truck. I have AutoEngenuity to help diagnose. Issue was only occurring on long drives after engine warm, but one day from cold start could build no boost, and rpm up and down roughly from 1500-2500 rapidly and could not increase speed over 10-20 mph. After 10-20 seconds boost would build up and rpm would stabilize and performance would return. Also to note smoke from exhaust would increase, and if memory is correct color was dark, not white. This started only within the last few weeks, and has occurred intermittently, and has recently not acted up.

Recent DTCs:
P0299 Turbo / Super Charger Underboost
P0404 Exhaust Gas Recirculation Circuit Range / Performance
P0405 Exhaust Gas Recirculation Sensor A Circuit Low
B1318 Battery Voltage Low

Recent repairs:
New batteries
Replaced fuel pressure regulator seal and performed blue spring upgrade
Replaced cold side CAC tube (stock plastic one had hole)
Replaced GPCM
Coolant Flush - Changed to ELC
Degas bottle
Water pump
Radiator cooling fan clutch

Things to troubleshoot/clean/repair:
VGT clean unison ring etc
VGT solenoid
EGR valve carbon
Oil cooler housing leak


Any ideas or additional info needed, let me know.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #2 ·
Never figured out what caused this, have made numerous repairs and I think this has stopped but hard to know because this was intermittent issue.
 

·
Compression Ignition Addict
Joined
·
9,360 Posts
fyi - P0405 is an EGR Sensor A Circuit Low. This code almost always means a bad EGR valve, caused by a bad coil in the valve, or (RARELY) a bad connector. Cleaning an EGR valve for this code is a waste of time.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Since cleaning EGR valve and replacing turbo (unison ring sticking, was hoping for increased performance but did not get that, should not have replaced) I have not seen that code again. Not doubting you are right and if it shows up again I will replace it after inspection of harness & connectors.
Thanks for your reply.
 

·
Registered
Joined
·
14 Posts
Since cleaning EGR valve and replacing turbo (unison ring sticking, was hoping for increased performance but did not get that, should not have replaced) I have not seen that code again. Not doubting you are right and if it shows up again I will replace it after inspection of harness & connectors.
Thanks for your reply.
I'm no good at the codes you show but looking at my truck history, It shows surging rpm's & it was a faulty Fuel Injector Control Pressure Sensor. The parts you may throw at it may be cheaper than taking it into a shop where SOME shops do the same thing.
 
1 - 5 of 5 Posts
Top