Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
:confused:I have a 2005 F-350 engine turns over but will not fire. I have checked or replaced most sensors on the truck, with the exception of the IPR, & IPC. I replaced the STC fitting on the HPOP and installed updated standpipes and dummy plugs. New crank and cam sensors, I have a Scanguage II on it and the FICM has good voltage. here is a short video clip of me trying to start it. Any help would be greatly appreciated. Thanks!
 

·
Registered
Joined
·
238 Posts
What is the ICP and fuel pressure. Or is fuel present in the secondary filter and the pump runs?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
There is fuel in the rail and in the secondary fuel filter. I have cracked open the filter top while cranking and where the fuel line goes into the injector rail. The ICP when unplugged will read like 1774, but still wont start. the ICP does not move when turning over the motor.
 

·
Registered
Joined
·
29 Posts
Did you figure it out? You were getting no pressure on the ICP which needs to be 500psi minimum to fire the injectors. You unplug the ICP sensor and try to start it. That will make it default to a higher pressure and it'll run. If it does, I'd suspect the ICP sensor itself. If it don't run it looks like a high pressure oil leak.

If it don't start, I'd take the IPR valve out behind the turbo. I took my turbo out to do this in about 20 minutes which was a lot easier for ME than just taking the FICM out and trying to yank it out that way. Too cramped! Lisle sells a special socket for that, CHEAP! See if the screen is still on it or damaged. If that screen comes off it won't start.
 
1 - 5 of 5 Posts
Top