Ford Powerstroke Diesel Forum banner
1 - 20 of 43 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I've got a 2004 F350 I just installed warren 155/30 injectors an airdog 165 fuel pump head studs and an edge with attitude turner. It ran fine after got it back together. I have probably put 150 miles on it. I was driving up interstate at about 75 and it lost power and died. I tried to restart but wouldn't so had it towed. Now it starts but immediately dies and sometimes it will run for 30 seconds but if you push the accelerator it dies. Any advice would be greatly appreciated.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #4 ·
Thought I had it fixed. Checked the electrical connections and they had water in them so I removed the edge tuner and it started right up. I've been driving it for a week and a half and went through another heavy rain storm and it shut down again. I tried the electrical connections on the pcm and the had a little moisture. I've checked everything with my torque pro app and I'm losing ficm sync after it hits. And I'm not getting cam and crank sync.
 

·
Registered
Joined
·
2,158 Posts
Check the cam and crank sensors for water. If you find water, dry it out (of course), see if it runs, if so, then get some dielectric grease from a marine shop, put that in any connections that have/had water in them.
Also, make sure the plugs to the ficm are snapped tight.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #8 ·
I also replaced the cam sensor and checked the wiring and it's fine. When I try to start it it hits and hip jumps to like 1100 to 1500 and IPC 44.5 but when I turn on key it shows 0 on ficm and cam crank sync but when I try to start it goes to 1 and then goes to 0 when I let key off. If I could post a video you could see it.
 

·
Compression Ignition Addict
Joined
·
10,212 Posts
Oh, and you need a certain minimum posts to be able to upload your video. I can't remember exactly how many posts, maybe 20.
 

·
Compression Ignition Addict
Joined
·
10,212 Posts
I meant, that that is normal to have 0 for sync with just the key on (ie no cranking)
 

·
Compression Ignition Addict
Joined
·
10,212 Posts
When you crank, post up the rpms that the scan tool reports. Also post the readings for fuel (injector) pulse width and mass fuel desired.
 

·
Compression Ignition Addict
Joined
·
10,212 Posts
Remove the secondary fuel filter and remove diesel from the filter housing. Have someone turn the key on (do not crank) while you watch the housing fill with diesel. It SHOULD fill fast. Post how many seconds it takes to fill and watch for bubbles when it fills.

Then look up youtube videos on doing the bubble test when cranking. It will tell you if you have an injector leaking combustion gas back into the fuel rail. You will want to leave the key in "off" and crank with the starter solenoid wire jumpered to the passenger side battery "plus" cable.
 
1 - 20 of 43 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top