Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
After tear down to install oil cooling gasket leak, put all back together after replacing all O-rings and gaskets. Started fine ran it down the road and it started hesitating and acting like it got no fuel.... Fuel gauge went from 3/4 to Empty.... Disconnected batteries and reconnected, still wont start fuel gauge back to 3/4 but pulling P0603 (Internal Control Mod KAM Air) and P1000 (Monitor checks not complete. Still will not turn over.... ALL lines checked.... And Ideas? :crazy:
 

·
information regurgitator
Joined
·
6,293 Posts
When you turn they key, all you hear is a click and nothing else happens?
The P0603 code is probably from disconnecting the batteries
The P1000 code is because you have not had the engine running long enough for a complete cycle.
Neither of them would be out of the norm, considering what you have done.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
No it tries to turn over but won't, then the batteries start to die (Batteries are less than a year old) It ran for about 15 minutes... Now it just won't turn over, Replaced oil and fuel filters. Just won't turn over. When it ran for those 15 minutes it was a rough idle like it wasn't getting fuel, when I drove it; it hesitated and then leaped like a surge, and then when I stepped on the gas peddle it would go, and the second I took it off, it dies and wouldn't restart. Had to have it towed...
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Also had the EGR Valve replaced less than 6 months ago. We cleaned it as it looked like it had never been cleaned or replaced.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Was reading your Cooling system link, I did clean out the HPOP res. but not all the way, but I did not add any oil back in there before putting it back together, I assumed when I put the oil back in that it would refill on it's own....
 

·
information regurgitator
Joined
·
6,293 Posts
Your choice of words describing what is happening is very confusing... so lets get the definitions correct first:

If the engine does not "turn over," then it would be seized/hydrolocked.
If it does not "turn over" all you would hear is the starter engage and and the engine would not move (if the starter/solenoid is not the issue).

If the engine cranks/turns over but does not fire, it won't start.
 

·
information regurgitator
Joined
·
6,293 Posts
Was reading your Cooling system link, I did clean out the HPOP res. but not all the way, but I did not add any oil back in there before putting it back together, I assumed when I put the oil back in that it would refill on it's own....
Oil would refill the cavity on its own. If you are having problems with what I think you are describing immediately after doing the oil cooler, then you may just have and air bubble in the High Pressure Oil system. It will work its way out on its own, once you get it running steady. Get it out on the highway and bring it to a stop, and do a few WFO runs.
If that doesn't help, try yanking your IPR and checking the screen. If it plugged up with junk, get a rescreen kit from Ford and rescreen it..but if there is a dent in the screen it may be best to buy a new IPR.
 
1 - 9 of 9 Posts
Top