Ford Powerstroke Diesel Forum banner

1 - 20 of 49 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #3
I have replaced the turbo with a ford reman
Turbo replaced cac cooler replaced map sensor
Truck has 250 thousand on the odometer truck was running great shut truck off went in to the store came out started truck and took off no power no boost like someone shut of a light switch
 

·
Premium Member
Joined
·
3,756 Posts
Check the harness for damage at the turbo -- lots of heat there and the insulation gets brittle
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
My vgt is cycling and working properly performed pinpoint for map and maf all checked it fine
 

·
Compression Ignition Addict
Joined
·
5,999 Posts
On vehicles built before Sept 29, 2003 (PCM ignores EBP sensor input and infers the value from the MAP and MAF sensors). On these vehicles, the MAF is used for fuel correction. The PCM will learn MAP and MAF and then learn the VGT action by cycling the VGT duty cycle in steps from 85% to 0%, and then back up, again in steps. It will learn the MAP and MAF action during this process. It takes 6 cycles to learn the VGT. P132b will be set if the PCM determines that there is something wrong with what it learned for MAP and MAF as it relates to VGT duty cycle.

Maybe a MAF sensor issue? Still might be a VGT actuator issue - I assume that the rebuilt turbo did NOT come w/ a new VGT actuator?
 

·
Premium Member
Joined
·
3,756 Posts
Should be able to force a VGT relearn on those models ..correct?
 

·
Compression Ignition Addict
Joined
·
5,999 Posts
Yes. He should be able to do that.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #10
ok Koeo readings map v 1.32 / map psi 14.79 / Maf v 0.05 /0.00 g/s / baro v 4.60

Koer map v 1.32 / map 14.79 psi /maf 1.5v /maf30.05 g/s / baro 4.60 v

Watching pids vgtlrn No and vgtvp count stuck on 1
 

·
Registered
Joined
·
25 Posts
Discussion Starter #11 (Edited)
Koeo pid readings map 1.32v /map 14.79 psi/ maf 0.05 v/ maf 0.00g/s baro 4.60v

Koer map1.32v /map 14.50 to 14.79 psi /maf 1.50 v /maf 30.32 g/s /baro 4.60 v

Vgtlrn no and my vgtvp- le stays at -1

Iat 68.00f
Iat 3.22v

Iat2 82.40f

Iat2 3.47v

I do appreciate all who are throwing ideas my way thanks again

Sitting watching vgtdc varying from 85% to 15% and vgtlrn-CNC no
 

·
Compression Ignition Addict
Joined
·
5,999 Posts
I don't understand Baro volts at 4.6, can you get a Baro pressure reading in addition to the volts?

Do you still have an functional EGR system? If so, maybe the EGR valve is plugged up.

You also might try unlugging the EBP and seeing if that helps.

Lastly, post up the v-reference voltage (KOEO, cranking, idle).
 
  • Like
Reactions: Hydro

·
Premium Member
Joined
·
381 Posts
I have an 03 build date of 04/03. I had similar issues about 12 years ago, I can't remember what was wrong back then, OLD AGE!!!
Anyway, I think I had a small tear in the boot hot side, dunno for sure, sorry.
FYI, I have a S&B after market intake; the 132b code is always present, truck runs fantastic!!
The code use to bug me, but someone told me it was cus of the intake, someone here.
IIRC the problem was intermittent, wish I would have written it down, so I could help.


Sent from my SM-G965U using Tapatalk
 

·
Premium Member
Joined
·
3,756 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #16 (Edited)
I have a functioning egr it is new performed baro pin out all checkers out good

Back pressure sensor is new removed tube from manifold and cleaned it and reinstalled it

Vref v 4.99

Playing around koer now throwing code p2263
 

·
Compression Ignition Addict
Joined
·
5,999 Posts
P2263 - Stuck turbo, MAP sensor, MAP hose plugged or leaking, CAC hose disconnected or leaking, intake leaks, exhaust restriction, exhaust leaks, EBP sensor or EBP tube plugged, or bad VGT solenoid. This code is set when MGP does not go over 15kPa or 2.2 psi when the following conditions are met: rpm must be over 2800; VFDES above 35; and EGRVP above 0.10. All of these conditions must be met for 5 seconds for the code to be set. This code is also used to detect a charge air cooler hose that has become disconnected. This code can also be set if there is ANY condition that would produce low power.

2003 engines that have been reflashed will not have issues with the EBP tube being plugged as the 06E17 action (flash) eliminated the EBP input and the EBP is now inferred.
 
  • Like
Reactions: Hydro

·
Registered
Joined
·
25 Posts
Discussion Starter #18
Ok today’s update I needed to change my Oil cooler So I tore down top of engine again removed the oil cooler and high pressure pump
Replaced them while apart I put my intake in a hot tank parts cleaner and totally cleaned it and some other parts while apart I opened up the turbo again unison ring moves so easy opened up the plunger for the vgt actuator and checked the indexing of it it is spot on put truck all back together again fired up the truck let it run to operating temp cleared codes with ids I monitored all vgt pids on my IDS still can’t get it to learn
I cleared codes performed koeo no codes ran a koer it popped up a p 2263 code can’t understand vgt is clean replaces vgt solenoid new map sensor new cac cooler new hpop new oil cooler new back pressure sensor no exhaust leaks or intake leake pressure tested both any ideas
 

·
Registered
Joined
·
25 Posts
Discussion Starter #19
While rebuilding the top end I ran the truck with the valve covers off and noticed oil leaking from the the injector cups is it possible that the injectors aren’t receiving enough oil pressure to supply the engine with the fuel it needs at idle to Perdue boost at idle
 

·
Compression Ignition Addict
Joined
·
5,999 Posts
Remove the MAP sensor hose and look it over VERY closely, if you haven't already done so.

I would still like to see the Baro value (not volts, but pressure).
 
  • Like
Reactions: Hydro
1 - 20 of 49 Posts
Top