Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Have and 03 6.0 that shut down riding down the freeway. It is throwing a ficm code but it is testing 47v. I am not sure what it could be. I know that the hpop's on the 03's were pretty good.

When the truck is cold it runs good then after it warms up it sputters then shuts off. If I turn the key back on it will not start. But, if I completly turn the key off and back on it will start and run good for a min then sputter and die like it is running out of fuel.

Any advice or help would be greatly appreciated. Mechanic is wanting to put on a ficm but, to me that is throwing away money if it is testing ok? Wiring harness maybe?
 

·
Premium Member
Joined
·
6,292 Posts
I know that the hpop's on the 03's were pretty good.
Where did you hear that? The 03 and 04 pumps are actually a well known failure point.
Test your fuel pressure, and monitor ICP when this happens. I think it is a high pressure oil system problem.
Leading candidates are the o-ring on top of the HPOP, The HPOP itself, the standpipes or the o-rings on top of the injectors at the rail.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
Thanks for the info. I have been leaning that way myself but would it be throwing a ficm code for the ICP or HPOP?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
I am trying to get in touch with the mechanic now to find the number/numbers. I will post them as soon as I get in touch with him.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #6 ·
Ok it is throwing u0105 Lost ficm to pcm conection and P0683 GPSM to pcm connection. Any thoughts? Wiring harness?
 
1 - 6 of 6 Posts
Top