Ford Powerstroke Diesel Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I've got an issue here on this Excursion it is equipped with only a triple dog and a cold air intake.


I have had this since it had 180k miles on it now has 245k on it been pretty flawless for most part 2 inj were put in back in may of this year on the pass side back 2 and I went ahead and had a new oil cooler and egr delete done as preventive maintenance, I drive this with my family daily so I don't want a break down.. Last week it had number 4 injector fail so I bought 4 new ones and replaced them all on the drivers but it only needed 1, labor is the same on 1 or 4 so I did all of them all on drivers side..

My issue is that driving down the road it acts like it just goes into stock power on its own no power at all just stock, stop at the store shut it off and it sits for like 30 mins it will run good again maybe 5 miles maybe 300 it went 300 this weekend no issues then on way home it did it all the way home like its not getting fuel it just puzzles me? I've pulled all of the codes with the triple dog and it only shows egr stuff it runs great I've always run the triple dog on extreme I don't run the tar out of it I just use for the fuel mileage and the ease of acceleration when passing.. Ive tried to change the power levels driving and it does not make any difference at all.. Any help would be great. Thanks call text or reply 573-202-9999
 

·
Registered
Joined
·
109 Posts
Make sure that dang butterfly valve is not in the intake. Remove the elbow and look into the intake. If there is a round metal plate in the intake remove it and throw it as far as you can. Don't drop the torx screws into the intake! It was only on 03 and some 04 models.
 
  • Like
Reactions: Heavy_GD

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I had the fuel filters changed today and it never did it one time after they were changed, only been 12k miles since the last ones were changed out I gues I'm gonna start doing it every 10k. But I will check the butterfly deal out, it does not need to be there? Thanks.
 

·
Registered
Joined
·
109 Posts
Correct, it does not need to be there.
 

·
Registered
Joined
·
120 Posts
Mine is a earley 2003, and do not have this butterfly, but it has the black plastic outside it, and cabels conected to it.
Had this truck since new, so its been like that all time.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top