Ford Powerstroke Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
i just resolved a no start w this damn truck

nothing special. just wouldn't start. other than restoring fuel pressure from 55 to 65 psi w a new regulator spring, there was nothing else done to the truck

i get it running and take it up the street to test drive it and the damn cluster goes out. checked all typical cluster fuses 35 and 41 - only fuse that isn't working is 42 its dead on both sides of the fuse

radio busted and i don't have power anything in the truck so i wouldn't notice accessory delay stuff anyway.

i have already taken the dash out and removed the cluster - anybody got a testing procedure i can follow?

i have a same year make and model truck w a blown trany that has the parts so i can test off known good stuff if needed
 

·
Registered
Joined
·
3,072 Posts
Send it to Circuit Board Medics, they can fix it for you.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #3
I can fix it ignores I know the board is def fried. Trying to get to that point before I pull every fuse and plug and remove it. It’s a pain

Anybody know where fuse 42 power comes? It’s dead on both sides and the fuses down the line all have power. I’m guessing 42 draws power from some other place.
 

·
Premium Member
Joined
·
8,226 Posts
I think if you turn the key to On, with the trip odometer button held Down for 5secs, it will enter "Test Mode" and you toggle through results by pushing the trip OD button again & again. Not sure what those results are all going to mean, but it's a Start ;)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
removed the fuse box and check power to multiple locations - this fuse box has seen better days and its obvious from some damage that water has been in the box and there is some corrosion, I couldn't find any bad spots on the board and have continuity to pins for the pins i'm having issues.

Relay 306 is tested and works. when fused and the relay is closed, i have continuity from the main hot on the board thru the pinout. This seems to me that I have a problem w the incoming or ground to make Relay 306 fire. anybody know where the hot wire comes from for Relay 306?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
i hate not posting a resolution for others. But, fuse 35 and 41 isn't all the cluster power fuses. fuse 33 which is listed as 'wipers' actually feeds a couple other lines, including the cluster. this fuse was burned i'm guessing b/c i removed the entire fuse box, disassembled and tested everything, then i discovered a publication online w all the circuits. i read them all and chased them all - and fuse 33 provides some power to the cluster.
 
1 - 6 of 6 Posts
Top