Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
2001 7.3 auto, rebuilt transmission 20k-25k ago but the truck sat for about a year and a half until 3 days ago when I started driving it (right after a cold air intake/replaced injectors and GP/upgraded to 38R turbo but I doubt any of that has to do with the problem). The first 2 days 0 problems, this morning after getting of the highway and down to 30-40mph speed zones, the truck seems to lurch a little bit when I’m lugging at about 30mph with light pedal pressure. Seems like the TC is locking and unlocking for no reason. Haven’t found any other threads specific to this. Truck has a TS6 other than that and what was mentioned above it’s stock. 250K miles and I just dumped 4K into a transmission at about 225k-230k. Any ideas? Seems to do fine at highway speeds or if I get on the pedal from a stop up passed the 30-35 mph area.
 

·
Registered
Joined
·
512 Posts
2001 7.3 auto, rebuilt transmission 20k-25k ago but the truck sat for about a year and a half until 3 days ago when I started driving it (right after a cold air intake/replaced injectors and GP/upgraded to 38R turbo but I doubt any of that has to do with the problem). The first 2 days 0 problems, this morning after getting of the highway and down to 30-40mph speed zones, the truck seems to lurch a little bit when I’m lugging at about 30mph with light pedal pressure. Seems like the TC is locking and unlocking for no reason. Haven’t found any other threads specific to this. Truck has a TS6 other than that and what was mentioned above it’s stock. 250K miles and I just dumped 4K into a transmission at about 225k-230k. Any ideas? Seems to do fine at highway speeds or if I get on the pedal from a stop up passed the 30-35 mph area.
You can monitor tcslip using torque or forscan.

Sent from my SM-N960U using Tapatalk
 
1 - 2 of 2 Posts
Top