Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2000 4x4 Excursion and when I turn the key to ON not start I have a very fast clicking from the Injector Controll relay under the hood intermittent clicking of the ICM I believe that is what it is it is under the drivers side battery tray under a rubber flap held down with three Christmas tree connectors. And i have after a few seconds clicking of the number 2 relay in dash. When the key is turned to Start I get a few weak cranks of the H.O. starter and then it just clicks as well.

I need this truck working please help. Also I use a edge evolution to pull codes and it cant connect to the PCM (the edge wasn't used on my truck I just have it for codes)



HELP!!!!
 

·
Premium Member
Joined
·
8,476 Posts
OK, first, the thing under the driver-side battery sounds like the ABS module, the ICP is in the front of the drivers-side head.

But, what you're describing, all these clicking relays and modules, sounds like low voltage or low current capability to them. Connect a volt meter to the Outlet (cig ltr) in the cab and see what's there before and during the crank attempt.

How are your batteries? To test them you need to fully charge them on a charger and have them, individually, Load Tested at a high rate (not the 100A the Auto Parts stores have, you need more like a 300A draw)

Next would be cables... How do they look? Any Green or White powder? You need to check them All, Both sides, to know if the amperage the batteries can supply (if they're good) can get to everything it needs to. Take them apart, scrape/clean/grease/tighten to make them right.

That's where I would start ;)
 
1 - 3 of 3 Posts
Top