Ford Powerstroke Diesel Forum banner

21 - 32 of 32 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #21
Percentage yes pids no id didn't say I had to I'll do that and see thanks
 

·
Registered
Joined
·
549 Posts
This is way over my head but I would be monitoring things like IPR, CPS, etc and see if you see something when it dies. My understanding is if the cel comes on, there is a code.

If you are using torque pro then download cargauge and see if it can see the codes. Cargauge also let's you run some tests.

Torque is better for monitoring and CG diagnostics. You can probably get by with the free version.

Sent from my SM-N960U using Tapatalk
 

·
Premium Member
Joined
·
4,037 Posts
I have had Torque miss a few codes, not sure if your model year comes into play on that or not
ForScan would be my goto tool for troubleshooting
the lite version I have not used, I use the PC version(free) and it is thorough in scanning
you do not need the extended license to use the software
 

·
Registered
Joined
·
549 Posts
This is way over my head but I would be monitoring things like IPR, CPS, etc and see if you see something when it dies. My understanding is if the cel comes on, there is a code.

If you are using torque pro then download cargauge and see if it can see the codes. Cargauge also let's you run some tests.

Torque is better for monitoring and CG diagnostics. You can probably get by with the free version.

Sent from my SM-N960U using Tapatalk
PS - they don't like switching between the 2. if you get some connect error then either reboot the phone or go into apps and force torque to stop. It takes control over the Bluetooth connection and must be stopped (at least on my device).


Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #26
Thanks guys I'll try it first thing tomorrow morning and see how it goes. About to head to the other side of the country for work and I'm worried it's going to die on me and not start out in the middle of nowhere
 

·
Registered
Joined
·
15 Posts
Discussion Starter #27
Ok so today while driving it dies and as I said the service engine light comes on after a couple minutes it goes off and starts but before it can go off I think about turning it over and watching the tach and it doesn't move cps right? I just put it in when all this started brand new from the dealer. I'll be checking the plug for it tomorrow short mrightaybe? But then it would be odd for the engine light to come on give a no start then start right up after waiting a few minutes
 

·
Premium Member
Joined
·
4,037 Posts
May be a spot in the harness near the plug, where you move it some when connecting the cps
 

·
Registered
Joined
·
15 Posts
Discussion Starter #29
Ok I checked all plugs again including the ones at the firewall and the Cps while the truck was running and nothing. Downloaded forscan lite and it pulled an a**load of codes I reset since they have never been cleared and I have changed ipr icp including the plug and the cps. I'll check them again the next time it dies. I do have a few reading from dashboard on forscan
768510
 

·
Premium Member
Joined
·
4,037 Posts
I dont like kPa for pressure, but yeah 514 psi is this at idle?
the 7% IPR is way low for idle, usually around 16-20%
and perdel on 3, 4, and 8

but a good start and you may be able to figure the problem when it happens (y)
 

·
Registered
Joined
·
15 Posts
Discussion Starter #31
Yeah thats at idle. I don't know why the ipr is so low it was just changed a week or 2 ago. I ran injector icp and ipr test forscan said it was all good. When I pulled codes they were all over the place. It was giving low hpop pressure and all kinds of stuff so I'm hoping it'll be a little bit more specific this time. My son is out driving it around now we're hoping it will die again and not take a week
 

·
Registered
Joined
·
15 Posts
Discussion Starter #32
I don't know what the deal is but it still hasn't died on me yet I'll pull codes and post when/if it does
 
21 - 32 of 32 Posts
Top