Ford Powerstroke Diesel Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Posted in another group as well.

Hey guys long time follower first time posting. Hopefully I have this posted in the right place my apologies if not.
I've done my best searching and reading but I can't seem to find a resolution to my problem. The truck will die randomly while driving or parked. The check engine light comes on when it dies after it sits for 5-10 minutes the check engine light goes off and it will start right up. I'm at 337k mi. no tuner or any performance parts.
I've done the airbox mod so its gone. Hutch and harpoon mod done so no clogged filters in the tank.
In the last week I have replaced the cps, ipr, icp, (all from the dealer) and fuel filter. Hasn't been but a few thousand miles since oil change and I've checked all the usual suspects for shorts/bare wires. pushed pulled and shook every plug i could find.
Also pulled the valve covers and checked injector harness and plugs. All injectors are firing when its running.

Runs fine before and after it dies doesn't run rough or anything.
 

·
Registered
Joined
·
516 Posts
Took it to O'Reilly's they checked it and there was nothing
They can't read us. Get forscan with a laptop or torque pro on Android and an adapter. There is a sticky on super duty diagnostics on the cheap.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
516 Posts
Any bluetooth adapter would work?
I recommend the better one but my cheap one works too. The obdlink MX is around $30 don't get the cheap $10 ones (mine works but sometimes acts funny... Like haha funny (slingblade reference))

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Looking at the Bafx 34t5 adapter it's about middle of the road as far as adapters go. Anyone use it?
 

·
Premium Member
Joined
·
3,756 Posts
Looking at the Bafx 34t5 adapter it's about middle of the road as far as adapters go. Anyone use it?
This is the one

The MX+ is faster, smaller, and has auto shut off -- the BAFX is cheaper and works well
both are good adapters
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
Just ordered the bafx it'll be here Thursday soon as I get it and find something out I'll post. I had read somewhere this morning that the ebpv could cause issues so disconnected it just to see but it died on me again so it's not that.
 

·
Registered
Joined
·
516 Posts
Just ordered the bafx it'll be here Thursday soon as I get it and find something out I'll post. I had read somewhere this morning that the ebpv could cause issues so disconnected it just to see but it died on me again so it's not that.
You can use it with your other cars too. I use it on my PoS Hyundai

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Yeah it's definitely a good investment. I always do my own work on everything
 

·
Registered
Joined
·
36 Posts
I have a similar problem. Runs down the road just fine until I get above 2200 rpm. Looses power. Shift to neutral. let it idle a few seconds and she runs just fine and then repeats. Shows check engine light. Shows no codes stored nor during live data... I have a good bluetooth and a direct connect code reader, or so I thought... I may have to upgrade.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #14
Never had mine do that. It started with a little hiccup here and there couldn't find the issue then it just dies and here I am even after replacing the usual culprits. Tomorrow I'll have my adapter and get torque pro downloaded and see if it finds anything.
 

·
Registered
Joined
·
36 Posts
I just ordered the AutoEnginuity Ford bundle from ktperformance.net. Looking forward to getting codes and running tests.
 

·
Registered
Joined
·
20 Posts
Posted in another group as well.

Hey guys long time follower first time posting. Hopefully I have this posted in the right place my apologies if not.
I've done my best searching and reading but I can't seem to find a resolution to my problem. The truck will die randomly while driving or parked. The check engine light comes on when it dies after it sits for 5-10 minutes the check engine light goes off and it will start right up. I'm at 337k mi. no tuner or any performance parts.
I've done the airbox mod so its gone. Hutch and harpoon mod done so no clogged filters in the tank.
In the last week I have replaced the cps, ipr, icp, (all from the dealer) and fuel filter. Hasn't been but a few thousand miles since oil change and I've checked all the usual suspects for shorts/bare wires. pushed pulled and shook every plug i could find.
Also pulled the valve covers and checked injector harness and plugs. All injectors are firing when its running.

Runs fine before and after it dies doesn't run rough or anything.
Sometimes you get a bad Cam Position Switch. I have had to replace two before I got one that would work.

I do not know of the proper bench check to test this item off the truck. Does anyone have an idea about the way to bench test a CPS?

AKWilly
 

·
Registered
Joined
·
5 Posts
Posted in another group as well.

Hey guys long time follower first time posting. Hopefully I have this posted in the right place my apologies if not.
I've done my best searching and reading but I can't seem to find a resolution to my problem. The truck will die randomly while driving or parked. The check engine light comes on when it dies after it sits for 5-10 minutes the check engine light goes off and it will start right up. I'm at 337k mi. no tuner or any performance parts.
I've done the airbox mod so its gone. Hutch and harpoon mod done so no clogged filters in the tank.
In the last week I have replaced the cps, ipr, icp, (all from the dealer) and fuel filter. Hasn't been but a few thousand miles since oil change and I've checked all the usual suspects for shorts/bare wires. pushed pulled and shook every plug i could find.
Also pulled the valve covers and checked injector harness and plugs. All injectors are firing when its running.

Runs fine before and after it dies doesn't run rough or anything.
Just went through a very similiar problem with my 2002 7.3. The cps I got from ford was faulty. Bought one from local international dealer and it worked fine. wasnt the problem it was the IPR sensor but just wanted to let you know that Ford has some faulty cps.
 

·
Registered
Joined
·
108 Posts
Most likely one of the big three... CPS, ICP, OR IPR. They can cause the issues of random dieing, CPS and IPR is most popular
 
  • Like
Reactions: greg heiden

·
Registered
Joined
·
15 Posts
Discussion Starter #19
Ok im sitting here with torque pro open my truck running and it dies the service engine light is on i searched for codes twice and it says no codes stored in ecu
 

·
Premium Member
Joined
·
3,756 Posts
Do you see the percentage counting up when you scan for codes?
and did you add the Ford specific PIDS in options?
 
1 - 20 of 32 Posts
Top