Ford Powerstroke Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter #1
Need some help big time so just got the truck back from the shop then installed new up-pipes and a new d66 turbo. Well i got a call that the mechanic went to test drive and had a terrible miss. so i informed them that one clip on the uvhc gaskets (driver side head at the front). So he worked on it and said it was fine but unplugged it and plugged back in and said the truck run great said it was a nice running truck 20 mile test drive. Well i took it and drove back up to work (20 miles away) ran wonderful pulled hard and everything, so got it there to work revved it up to 2000 rpm and let it idle down. Then 20 second later it made a loud click and started to miss and misses worse and worse till it makes a growl out the intake then smooths back out and wont do it again till you rev it back up and let it idle and then does it again. so i am at a lost and it sounds like the miss is on the passenger side. And driving home it did the same missed described in his test drive and if you push the clutch in for like 5 to 10 second and then smooths back out and runs great. he and me are both at a lost, what is all your thoughts?
 

·
Registered
Joined
·
3,835 Posts
Are you sure it's a miss and not a clutch problem of some sort?

Sent from my DROID BIONIC against my will
 

·
Registered
Joined
·
185 Posts
Discussion Starter #3
I am sure cuz you can really here the miss then you get a really deep growl sound out the intake


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
3,835 Posts
Good point, forgot you mentioned the intake noise. Personally i've never heard these symptoms. Best bet is to get it on a scanner

Sent from my DROID BIONIC against my will
 
1 - 4 of 4 Posts
Top