Ford Powerstroke Diesel Forum banner

1 - 20 of 61 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
while pulling trailer over weekend my truck started to lose power i switched tanks but kept doing the same it tried to hang on but finally died. had fuel in both tanks has been running with a miss for a while like a bad injector but it kept working so i kept driving it. have not checked anything yet any ideas thanks guys
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
7.3 shut off

no gauges just factory gauges that are no help, i was running and all of the sudden going down the turnpike it started to lose power switched tanks thinking its fuel and got a little better and then same thing lost power till it finally shut off.
 

·
Registered
Joined
·
1,482 Posts
When you try to start it now does the tac move?
 

·
Premium Member
Joined
·
134 Posts
Check your oil level. Running to low on oil will cause your injectors to stop working making it feel like it was running outta fuel. Had the exact same thing happen to me when I had bad injector o-rings, found out almost to late that my wife had let the oil level get to low and the truck died from it. Any way Just my 0.02c , maybe some one has a better idea?
 

·
Banned
Joined
·
5,630 Posts
always check oil level. whats it sitting at
 

·
Registered
Joined
·
705 Posts
Id check the fuel pressure at the schrader (spl?) valve of the bowl, cranking.

:ford:
I would not rule out the fuel pump either.
 

·
Registered
Joined
·
125 Posts
Have you checked your CPS yet? Also check for corrosion on the terminals on the PCM and IDM relays.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #10
thanks guys have not had a chance to check as work has been hectic but thank you all for your input i will check all of the things you have said, starting with the simple ones first might get lucky. ill keep you all posted.
 

·
Registered
Joined
·
1,189 Posts
if your oil is good and the tach moves I'd say you lost your fuel pump, First check to see if the bowl fills up when you crank the motor and then check fuel pressure at the shrader valve
 

·
Registered
Joined
·
22 Posts
Discussion Starter #15
well when i was driving i switched tanks and it still kept losing power till eventually it died, what type of pressure should it have thanks for ur input.
 

·
Registered
Joined
·
1,482 Posts
there is only one pump it is in the engine valley. on the side of the fuel bowl there is a shrader valve you can hook a gauge up to and see what you have for preasure
 

·
Registered
Joined
·
22 Posts
Discussion Starter #18
changed fuel pump and fuel filter, cleaned filter housing and small screen. but know i have a more serious problem fuel pump was stuck and upon removing, it broke and the rod fell inside motor i tried reaching it with a magnet and i heard it fall i think in the pan but not positive, so now i have to remove oil pan to check but it seems that i i have to raise motor in order for pan to clear cross member what else do i have to remove other than motor mount bolts.
 

·
Banned
Joined
·
5,630 Posts
do i have a fuel pump in each tank???? or are we taking injector pump
There is no injection pump on these.

changed fuel pump and fuel filter, cleaned filter housing and small screen. but know i have a more serious problem fuel pump was stuck and upon removing, it broke and the rod fell inside motor i tried reaching it with a magnet and i heard it fall i think in the pan but not positive, so now i have to remove oil pan to check but it seems that i i have to raise motor in order for pan to clear cross member what else do i have to remove other than motor mount bolts.
Which rod fell inside the oil pan???
 

·
Registered
Joined
·
1,482 Posts
I would guess its the rod on the bottom of the pump that rides on the cam shaft. And I believe you have to pull the engine out of the truck to remove the oil pan
 
1 - 20 of 61 Posts
Top