Ford Powerstroke Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
alright I got this 1995 7.3 PSD with 153,000 miles on it. It’s got new 180cc/30% injectors, tunes for injectors, new stage 2 HPOP, new 444fab e-fuel with regulated return, new oil pressure switch, new IPR, new EBPS, new oil temp sensor, new GPR and glow plugs. ICP hasn’t been replaced yet but it probably will be soon. The fact that my batteries aren’t charging doesn’t help anything but even when they were good and hot I had a small issue with getting it started. It’s not an extremely hard start but you gotta turn it over longer than you should to get it start. When it starts it busts right off with no chugging or anything. Runs smooth as heck And sounds great. I drove it one day and it fell on its face and fogged the street with white smoke and wouldn’t rev up over a somewhat rough idle but that was before the new fuel system. It’s got me kinda stumped. Y’all got any ideas?
 

·
Mr. Crossthread
Joined
·
4,379 Posts
Do you have a way to watch some PIDs while cranking? The white smoke incident could've been anything from IDM to injector, Ive also seen the engine harness rub on the drivers side valve cover causing a bunch of injector issues. Also, how much has this truck been driven since the high pressure oil system was opened up?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
I drove it like a mile since high pressure oil system has been opened up. I got excited and stomped on the pedal and it just fell on its face so I parked it and put the fuel system on it. I do have auto enginuity
 

·
Registered
Joined
·
26 Posts
Discussion Starter #4
I drove it like a mile since high pressure oil system has been opened up. I got excited and stomped on the pedal and it just fell on its face so I parked it and put the fuel system on it. I do have auto enginuity
 

·
Registered
Joined
·
1,637 Posts
I drove it like a mile since high pressure oil system has been opened up. I got excited and stomped on the pedal and it just fell on its face so I parked it and put the fuel system on it. I do have auto enginuity
Gonna take more than a mile of driving to purge the air from the HPO system.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #7
This truck is doing some weird stuff. Replaced the alternator, we’re charging good. Go to drive it a little bit to try and purge HPO system. Get it out on the road and roll up to 30mph and then give it the rabbit...runs like a scalded ape right until the speedo hits 60 and it falls on its face. It does this consistently every pass I make. Here comes the weird part. After it loses power I have barely any throttle and some white smoke until I stop and back the truck up a couple feet. Take off forward and it’s all good until I make another 30-60 pass. Anyone ever seen this happen?
 

·
Registered
Joined
·
2,874 Posts
Never heard of anything like that. Is the CEL illuminated? Cheers!
 

·
Premium Member
Joined
·
2,742 Posts
"until I stop and back the truck up a couple feet"
What does backing up have todo with the problem??
 

·
Registered
Joined
·
26 Posts
Discussion Starter #10
It will not throttle hardly at all after falling on its face. So I stop the truck, back up, put it back in 2nd and it goes back to normal throttle until I hit right dead on 60mph in 4th at WOT.
"until I stop and back the truck up a couple feet"
What does backing up have todo with the problem??
 

·
Premium Member
Joined
·
2,742 Posts
You already stated that -- I asked what backing up had todo with this problem -- care to clarify please

By 2nd gear, can I assume this is a stick transmission? -- in neutral the engine will still not rev up?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #13 (Edited)
I have no idea what backing up has to do with it other than temporarily fix my loss of power and I have no idea why it helps. That’s what I’m trying to understand. It is a manual transmission 2 wheel drive truck. Will not rev up in neutral
 

·
Premium Member
Joined
·
2,742 Posts
"Will not rev up in neutral"
So, only backing up a little will let the engine rev up? ...very odd

The engine shifts around a bit on the motor mounts when changing directions, possible you have a short in the harness that is affected by this movement -- I would think there would be codes popping up -- time to search the engine harness for worn/bare spots
 

·
Registered
Joined
·
26 Posts
Discussion Starter #15 (Edited)
Not a bad idea. I’ll pick through it. Is there any reason E-fuel with a factory super duty pump and regulated return set at 65psi not be able to support 180cc/30% injectors?
 
1 - 15 of 15 Posts
Top