Ford Powerstroke Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1
I have a 1993 Ranger 4.0 it runs like crap up to about 3K then takes off and will run hard . Also if you hold it at a stable RPM it misses.
Any Help please :bump:
 

·
If it aint a CAT itsa DOG
Joined
·
4,553 Posts
Did the older 4.0s have coil packs or a distributor? I know that the newer ford v8's are prone to coils going out which will cause a big miss. Also like ayp said, how are the plugs and wires?
 

·
Registered
Joined
·
115 Posts
Discussion Starter #4
Just Change the plugs a month ago , it has one ciol pack on the motor
 

·
Premium Member
Joined
·
3,578 Posts
My 94 has the coil packs together on the motor. Mine was acting up missing real bad a few months ago, had to remove the MAF sensor and clean it with carb cleaner, took 2 minutes to fix. Also have you checked it for codes?
 

·
Registered
Joined
·
115 Posts
Discussion Starter #6
No codes present I will try cleaning the MAF Thanks
 

·
If it aint a CAT itsa DOG
Joined
·
4,553 Posts
hopefully you don't need a new MAF. Those things aren't cheap. I put one in my wifes old for five hudnred and it was 100 bucks. i tried cleaning it first and it worked for one day and then her car wouldn't start.
 

·
Registered
Joined
·
1,822 Posts
Dont use carb cleaner on the MAF, it's not good for it. They sell MAF cleaner. Try that it actually helps. Comes in a gray can, can get it at like advanced auto. Usually helps. Do you have anything done to the truck? I know I put an intake on my 97 4.0 (last year for the OHV, same as yours) and it made it run kind of like you're saying, except it never really took off. Also check for vacuum leaks.

Another thought that just popped into my head. I had an EGR valve fail on my truck. I'd pull up to a stop sign and it would buck and hesitate, but never died, then as soon as I got on the gas again, it'd take right off like nothing was wrong. Is it throwing any codes?
 

·
Registered
Joined
·
115 Posts
Discussion Starter #9
First off thanks to all of you helping me with this . Yes my son did make his own cold air intake and no codes present, no check engine lite
 
1 - 9 of 9 Posts
Top