Ford Powerstroke Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter #1
a week ago today my truck wouldnt start it would crank just fine but it wouldnt start so i had it towed to the dealer and they said it was the fuel filters so they changed them and I got my truck back yesterday and this morning it wouldnt start again but now it has a knocking sound kinda like air trapped somewhere and it puffs black smoke when its tirning over.
 

·
Registered
Joined
·
8 Posts
Had same problem on my 05 Excursion. I took it to the dealer and they replaced the injectors and it runs fine so far. Good luck.
 

·
Registered
Joined
·
597 Posts
not necessarily. Sometimes things can fail and not set codes. Is this no-start when hot/cold, either??
 

·
Registered
Joined
·
146 Posts
Discussion Starter #6
Cold. when i went to start it this morning. and i also noticed the the cycleing noise you should hear doesnt last near as long as it should.
 

·
Registered
Joined
·
597 Posts
so if you can get it running, will it restart hot okay?
 

·
Registered
Joined
·
146 Posts
Discussion Starter #8
yea wen i got it yesterday after the fuel filters were changed i crank it up prolly 4 time and it was just fine.
 

·
Registered
Joined
·
597 Posts
it could, but it could also be a number of things, low ICP, low fuel pressure, bad FICM, bad IPR valve, bac ICP sensor. Where there any codes store in the truck??
 

·
Registered
Joined
·
119 Posts
Sorry for the highjack, I am having the same trouble.
Complete injector replacement (all 8) with new dummy plugs, new stand pipe rings, SCT fitting,new ICP, new IPR, new CPS, new glow plugs, turbo cleaned.
EGR deleted, RR fuel system. Took FOREVER to start after replacement (not the 30-45 seconds) I expected.

Once it starts and runs the first time for the day it fires right up every time.
If it sits overnite It won't start the next morning(without something spray).
cranks no prob, sputters, smokes, showing about 250 rpm on crank, 550 oil press, ficm voltages look ok. I crank it for 4 or 5 cycles, then get annoyed and give it some spray it fires right up and will restart every time after.

Can you give me any direction to look?

thanks
 

·
Registered
Joined
·
119 Posts
UPDATE!
I guess it was my wishful thinking.
RPM's in cold crank 150-170
warm/hot 150 starts immediatly

FMIC on cold KOEO 40-42v
cold crank 40-42v
warm KOEO starts 40 climbs to 47-48
warm crank 43-44
KOER 43-44

ICP 1100psi .24v

so, FMIC on its way out?
I would think a crank sensor would cause the same failure warm or cold no?
CPS has 200 miles on it, all yesterday.
 

·
Registered
Joined
·
4 Posts
no start low fuel pressure

I have a 04 F-350 6.0 i replaced 3 new fuel pumps in three days and i still have low fuel pressure.The dealer has no idea what the problem is.I drained the fuel tank ran air into the fuel lines.Still 25 psi fuel pressure. I can start the engine with a shot of starting fluid then the engine dies.Help
 

·
Registered
Joined
·
597 Posts
I have a 04 F-350 6.0 i replaced 3 new fuel pumps in three days and i still have low fuel pressure.The dealer has no idea what the problem is.I drained the fuel tank ran air into the fuel lines.Still 25 psi fuel pressure. I can start the engine with a shot of starting fluid then the engine dies.Help
stuck pressure regulator valve in secondary filter housing? I think that is where the valve is.
 
1 - 15 of 15 Posts
Top