Ford Powerstroke Diesel Forum banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
46 Posts
Discussion Starter #1
i have an '05, 6.0 with 140,000 miles. Heads, gaskets, egr delete, APR studs, FICM, cam and crank sensors, 2 injec tors all replaced in last 8 months. Was in the shop for 2 weeks, got it back 3 days ago. It went in stalling, no power, unable to get it over 20 mph. 2 injectors were replaced. It ran great until an hour ago. Really rough idle then stalled. I got it started, but it is belching white smoke and won't stay running. It is throwing codes P0263, P0281, P0291. No check engine light. The FICM was just checked last week and it's fine. I'm ready to go postal, this truck is kicking my arse. Any ideas what could be wrong:dunno:
 

·
Registered
Joined
·
263 Posts
What’s your fuel pressure if your throwing injectors at it having white smoke and stalling. I would check there.


Sent from my iPhone using Tapatalk
 

·
Compression Ignition Addict
Joined
·
7,081 Posts
i have an '05, 6.0 with 140,000 miles. Heads, gaskets, egr delete, APR studs, FICM, cam and crank sensors, 2 injec tors all replaced in last 8 months. Was in the shop for 2 weeks, got it back 3 days ago. It went in stalling, no power, unable to get it over 20 mph. 2 injectors were replaced. It ran great until an hour ago. Really rough idle then stalled. I got it started, but it is belching white smoke and won't stay running. It is throwing codes P0263, P0281, P0291. No check engine light. The FICM was just checked last week and it's fine. I'm ready to go postal, this truck is kicking my arse. Any ideas what could be wrong:dunno:
P0291 isn't a valid code. Is it a typo?
 
1 - 5 of 5 Posts
Top