Ford Powerstroke Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Ok I have a 2004 f250 6.0 seems to have a rough idle (sounds like a muscle car) kinda, I unplugged the icp and seems to run the same so does that mean the sensor is bad? also driving down the road it starts to jerk/buck at around 45-50 but if give it gas it goes on and smooths out. could this all be related?
 

·
Registered
Joined
·
4,914 Posts

·
Premium Member
Joined
·
51 Posts
I had the same issue and had injector #5 failure. It idled rough and would jerk/buck and seemed to shift weird till it warmed up. Also would clear up when I accelerate. I had it scanned at the stealership and they found the bad injector. I replaced the injector myself. Saved about 500.00 doing it myself. If you have one go bad the others typically follow. So think about doing as many as you can afford.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
i just took it to autozone and came up with p2285 I think it was. either way showed up as the ipc sensor sound right?
 

·
Registered
Joined
·
4,914 Posts
Could be, is there a sensor on your right front valve cover?

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
4,914 Posts
If not your icp is located under yhe turbo, 03 and early 04 are prone to icp and pigtail failure. Sometimes oil soaked.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
4,914 Posts
yeah i know its there but just didnt know how often they go out
Unless your hpop is taking a dump or you are developing a leak, you really need a monitor.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
4,914 Posts
Yea an icp reading is necessary, so there is no guessing whats going on.

Sent from my phone that somebody didn't help me get.
 

·
Registered
Joined
·
4,914 Posts
1 - 16 of 16 Posts
Top