Ford Powerstroke Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
you turn the key and it'll crank and crank, lift pumps has no power, injectors don't fire. even trying a hot wire strait to the pump, but it still isn't firing the injectors. no codes on the ecu.
some times you can slowly turn the key and the fuse box will chatter a way but not stay on. then out of the blue (or after 20 minutes of cycling the key) it'll start and run 30 seconds. cycle the key a few more times and it'll run, just don't turn it off.

where would you start, ignition switch? id think you'd start there, but way would everything have power but not fire? :doh:

i'm lost.
 

·
Premium Member
Joined
·
8,697 Posts
There is a connection, under the hood, where the fuseable links that feed the fusebox can corrode. Have a look there and see if you don't have a problem -> http://www.powerstroke.org/forum/99...sion-if-your-truck-like-mine.html#post1343921

Next, look to the WTS (WaitToStart) light on the dash. If it's not coming ON with the key, the PCM isn't running and not powering the pump or injectors. If that light doesn't come on when you first roll-on the key, don't even bother cranking. I would check ALL the fuses (especially #30-19-22), if your truck is chipped - remove it as a test, and finally you could check the PCMs connection itself.

If you have a WTS, like you're supposed to, then you need to monitor the sensors as well as check for codes. What are you using to scan your truck? You know our trucks are Not, strictly, OBD-II and those cheap generic scanners (like the Parts Stores use) are of little use...
 
1 - 2 of 2 Posts
Top